Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Caching issue after creating a Credit Memo Sales Invoice and completing it #5435

Open
TheBestPessimist opened this issue Aug 20, 2019 · 0 comments

Comments

@TheBestPessimist
Copy link
Member

commented Aug 20, 2019

Is this a bug or feature request?

Bug

What is the current behavior?

After running the whole cypress test suite on a dev instance, there is a caching issue with SI in list vs single view:

  • Single view: SI does not appear Paid ()
  • list view: SI is paid ()

Which are the steps to reproduce?

  1. Create SI
    • test lieferant
    • doctype = SI
    • product = convenience salat
    • qty = 333
  2. Complete SI
  3. Run action "Gutschrift erstellen"
    • Belegart = "Credit Memo"
    • false (default)
    • true (default)
    • true (default)
    • false (default)
  4. Select the new Credit Memo SI and complete it
    • it is paid
  5. Come back to the SI
    • in single view it is NOT paid
    • in list view it IS paid

A cache reset fixes this, but next time i retry this process, it will have the caching issue again.

Single view
image

List view
image

What is the expected or desired behavior?

Both single and list view should show the same information: that the SI is paid after completing the Credit Memo.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.