Permalink
Browse files

Add bundler.

  • Loading branch information...
1 parent 18a61f1 commit 427f720fbe232a8758cab6ccc6b17eed540f5dbd @metaskills committed May 11, 2011
Showing with 75 additions and 0 deletions.
  1. +13 −0 Gemfile
  2. +30 −0 Gemfile.lock
  3. +18 −0 config/preinitializer.rb
  4. +14 −0 db/schema.rb
View
13 Gemfile
@@ -0,0 +1,13 @@
+
+source :gemcutter
+
+gem "rails", "~> 2.3.11"
+gem 'sqlite3'
+
+group :development do
+
+end
+
+group :test do
+
+end
View
@@ -0,0 +1,30 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (2.3.11)
+ actionpack (= 2.3.11)
+ actionpack (2.3.11)
+ activesupport (= 2.3.11)
+ rack (~> 1.1.0)
+ activerecord (2.3.11)
+ activesupport (= 2.3.11)
+ activeresource (2.3.11)
+ activesupport (= 2.3.11)
+ activesupport (2.3.11)
+ rack (1.1.2)
+ rails (2.3.11)
+ actionmailer (= 2.3.11)
+ actionpack (= 2.3.11)
+ activerecord (= 2.3.11)
+ activeresource (= 2.3.11)
+ activesupport (= 2.3.11)
+ rake (>= 0.8.3)
+ rake (0.8.7)
+ sqlite3 (1.3.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ rails (~> 2.3.11)
+ sqlite3
View
@@ -0,0 +1,18 @@
+begin
+ require "rubygems"
+ require "bundler"
+rescue LoadError
+ raise "Could not load the bundler gem. Install it with `gem install bundler`."
+end
+
+if Gem::Version.new(Bundler::VERSION) <= Gem::Version.new("0.9.24")
+ raise RuntimeError, "Your bundler version is too old for Rails 2.3. Run `gem install bundler` to upgrade."
+end
+
+begin
+ # Set up load paths for all bundled gems
+ ENV["BUNDLE_GEMFILE"] = File.expand_path("../../Gemfile", __FILE__)
+ Bundler.setup
+rescue Bundler::GemNotFound
+ raise RuntimeError, "Bundler couldn't find some gems. Did you run `bundle install`?"
+end
View
@@ -0,0 +1,14 @@
+# This file is auto-generated from the current state of the database. Instead of editing this file,
+# please use the migrations feature of Active Record to incrementally modify your database, and
+# then regenerate this schema definition.
+#
+# Note that this schema.rb definition is the authoritative source for your database schema. If you need
+# to create the application database on another system, you should be using db:schema:load, not running
+# all the migrations from scratch. The latter is a flawed and unsustainable approach (the more migrations
+# you'll amass, the slower it'll run and the greater likelihood for issues).
+#
+# It's strongly recommended to check this file into your version control system.
+
+ActiveRecord::Schema.define(:version => 0) do
+
+end

0 comments on commit 427f720

Please sign in to comment.