Skip to content


Subversion checkout URL

You can clone with
Download ZIP
The most popular front-end framework for developing responsive, mobile first projects on the web for Rails asset pipeline.
Ruby Shell CSS JavaScript

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.

Less Rails Bootstrap

Bootstrap is Twitter's toolkit for kickstarting CSS for websites, apps, and more. It includes base CSS styles for typography, forms, buttons, tables, grids, navigation, alerts, and more. To get started -- checkout!

The less-rails-bootstrap project hooks into less-rails ( to provide both compiled and LESS CSS source files from the Twitter Bootstrap project within the Rails 3.1 asset pipeline. Benefits:

  • Assets are namespaced in twitter/bootstrap to avoid asset conflicts.
  • Top level requires to get all stylesheets or javascripts.
  • Ability to import or require individually namespaced stylesheets or javascripts.


This gem will directly track the semantic versioning releases of the Twitter Bootstrap project. Our major and minor versions will always match to theirs. Tho we may have tiny patch level releases specific to this gem.


This library requires the less-rails gem to work. Unfortunately, I have yet to publish my gem in the abandoned less-rails space on Till then, please bundle less-rails using the git repo.

gem 'less-rails', :git => 'git://'
gem 'less-rails-bootstrap', '1.3.0' 


The easiest way to use Twitter Bootstrap is require it in your application.css file. Doing so will compile the complete LESS libraries files for Bootstrap.

 *= require twitter/bootstrap

#foo {
  /* Your styles... */

In a file with the .css.less extension, you can import the entire Bootstrap LESS framework. This will allow you to use Bootstrap's variables and mixins in your CSS that follows. Remember, unlike other CSS frameworks, requiring or importing Bootstrap will include all the CSS for building a bootstrapped website. If you only want variables or mixins, you will have to import those discreet files.

@import "twitter/bootstrap";

#foo {

Maybe all you want to use is the variables and mixins that come with Twitter Bootstrap. No problem, just import them individually from you own .css.less file. In this case only the #foo selector is output.

@import "twitter/bootstrap/variables";
@import "twitter/bootstrap/mixins";

.myButton(@radius: 5px) {

#foo {

Using the JavaScript files is just as easy. Again, you can include all them with a single directive from your application.js file. Optionally, you can require only the files you need like require twitter/bootstrap/modal.

//= require twitter/bootstrap




Twitter Bootstrap Project:

Copyright 2011 Twitter, Inc.

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

Less::Rails is Copyright (c) 2011 Ken Collins, and is distributed under the MIT license.

Something went wrong with that request. Please try again.