Permalink
Browse files

Officially support JRuby

Depend on the most recent version less (>= 2.2) 
which does not depend on therubyracer.
  • Loading branch information...
1 parent 5afcdb5 commit d5bf1a004950281fb9d9ed2155921a87463b8053 @cowboyd cowboyd committed Apr 25, 2012
Showing with 6 additions and 1 deletion.
  1. +2 −0 .travis.yml
  2. +3 −0 CHANGELOG.md
  3. +1 −1 less-rails.gemspec
View
2 .travis.yml
@@ -3,6 +3,8 @@ rvm:
- 1.9.2
- 1.9.3
- ree
+ - jruby-18mode
+ - jruby-19mode
before_install:
- gem update --system
gemfile:
View
3 CHANGELOG.md
@@ -1,6 +1,9 @@
CHANGELOG
=========
+* Remove explicit dependency on therubyracer
+* Add jruby and jruby --1.9 to travis configuration
+
2.2.1 - 04/15/2012
* Make it usable with therubyrhino (and older versions of therubyracer as well). Fixes #36.
View
2 less-rails.gemspec
@@ -14,7 +14,7 @@ Gem::Specification.new do |s|
s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_runtime_dependency 'less', '~> 2.1.0'
+ s.add_runtime_dependency 'less', '~> 2.2.0'
s.add_runtime_dependency 'actionpack', '>= 3.1'
s.add_development_dependency 'minitest'
s.add_development_dependency 'guard-minitest'

0 comments on commit d5bf1a0

Please sign in to comment.