Permalink
Browse files

Make it work with all rails versions. Hard to test tho!

  • Loading branch information...
1 parent 08bfb42 commit 5f0d8ddf240b00e5e498808a4243bd8ebfb86976 @metaskills committed Jan 3, 2012
Showing with 11 additions and 4 deletions.
  1. +6 −1 Gemfile
  2. +1 −1 lib/mini_backtrace.rb
  3. +1 −1 mini_backtrace.gemspec
  4. +3 −1 test/test_helper.rb
View
@@ -1,2 +1,7 @@
source :rubygems
-gemspec
+
+
+gem 'minitest', '> 1.2.0'
+gem 'rails', '2.3.14'
+
+
View
@@ -1,3 +1,3 @@
-require 'rails'
+require 'rails/backtrace_cleaner'
require 'minitest/unit'
require 'mini_backtrace/unit'
View
@@ -16,6 +16,6 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ['lib']
s.add_dependency('minitest', '> 1.2.0')
- s.add_dependency('rails', '> 2.3.2')
+ s.add_dependency('rails', '> 2.3.14')
end
View
@@ -1,5 +1,7 @@
+require 'rubygems'
require 'bundler'
-Bundler.setup
+require "bundler/setup"
+Bundler.require
require 'mini_backtrace'
require 'minitest/spec'
require 'minitest/autorun'

0 comments on commit 5f0d8dd

Please sign in to comment.