Skip to content

meteor does not run on node 0.7.x #132

Closed
TomWij opened this Issue May 10, 2012 · 1 comment

1 participant

@TomWij
TomWij commented May 10, 2012

For Windows support to work as well as to prepare for the future, we need meteor to be able to run on 0.7.x.

Most packages versions meteor uses are not compatible with 0.7.x, newer versions might be but we need to check if that doesn't break anything. And I don't think that's something feasible to do on my own, so I wonder whether other people would be interested looking into making Meteor ready for 0.7.x.

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: package@version
npm ERR! Required: {"node":">= 0.5 < 0.7"}
npm ERR! Actual:   {"npm":"1.1.18","node":"0.7.x"}

I'm in doubt whether the following has already been resolved:

npm install "connect@1.8.7" # not 2.x yet. sockjs doesn't work w/ new connect

The most recent version of gzippo doesn't seem to support 0.7.x, which might as well be a show stopper:

npm install "gzippo@0.1.4"

And there are probably more problems with the other packages.

@TomWij
TomWij commented May 10, 2012

This is no longer needed for Windows and I guess 0.7.x might be still early...

@TomWij TomWij closed this May 10, 2012
@dandv dandv added a commit that referenced this issue Nov 6, 2012
@dandv dandv Minor grammar fix in livedata_connection.js
While looking for a potential solution to [#132](/meteor/meteor/issues/139#issuecomment-10090472)
e8f1510
@haircuttedfreak haircuttedfreak pushed a commit that referenced this issue Jan 5, 2013
@dandv dandv Minor grammar fix in livedata_connection.js
While looking for a potential solution to [#132](/meteor/meteor/issues/139#issuecomment-10090472)
efbc5a7
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.