Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Meteor mongo doesn't see local database #4124

Closed
sdomagala opened this issue Apr 4, 2015 · 6 comments
Closed

Meteor mongo doesn't see local database #4124

sdomagala opened this issue Apr 4, 2015 · 6 comments

Comments

@sdomagala
Copy link

@sdomagala sdomagala commented Apr 4, 2015

As states in title, meteor mongo leaves error:

mongo: Meteor isn't running a local MongoDB server.

This command only works while Meteor is running your application locally. Start
your application first. (This error will also occur if you asked Meteor to use
a different MongoDB server with $MONGO_URL when you ran your application.)

If you're trying to connect to the database of an app you deployed with
'meteor deploy', specify your site's name with this command.

I found a way around, but I just don't know why after update meteor mongo stopped working.

My way:

apt-get install mongodb-clients
mongo localhost:3001/meteor

Meaning that local database is visible, just not for meteor mongo

@dcsan
Copy link

@dcsan dcsan commented Apr 4, 2015

one of our team just noted this too on linux.
on osx it seems fine for me tho...

@rclai
Copy link

@rclai rclai commented Apr 5, 2015

I'd like to +1 this as well. I'm on Trusty Tahr.

@Slava
Copy link
Member

@Slava Slava commented Apr 5, 2015

Possible duplicate of #4115

@glasser
Copy link
Member

@glasser glasser commented Apr 5, 2015

Yes, this is a duplicate of #4115, which @stubailo was in the process of releasing 1.1.0.2 to fix on Friday. It appears that the last stage or two of the release process never happened. Trying to get in touch with him to find out why, since many users are hitting this.

@glasser glasser closed this Apr 5, 2015
@stubailo
Copy link
Contributor

@stubailo stubailo commented Apr 6, 2015

The fix has just been released in 1.1.0.2.

@mohessaid
Copy link

@mohessaid mohessaid commented Nov 1, 2015

Still get the same problem in 1.2.1?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants