New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[1.6.1.1] Windows April Update: Cannot find module 'fibers' #9863

Closed
Rhywden opened this Issue May 5, 2018 · 18 comments

Comments

Projects
None yet
@Rhywden
Contributor

Rhywden commented May 5, 2018

Long story short: After the latest Windows April Update a previously working 1.6.1.1 installation now yields this:

image

@Rhywden Rhywden changed the title from [1.6.1] Windows April Update to [1.6.1] Windows April Update: Cannot find module 'fibers' May 5, 2018

@Rhywden Rhywden changed the title from [1.6.1] Windows April Update: Cannot find module 'fibers' to [1.6.1.1] Windows April Update: Cannot find module 'fibers' May 5, 2018

@atfera

This comment has been minimized.

atfera commented May 7, 2018

I have the same issue, also after the April update, and now I can't go back to the old version because I deleted the old save \o/ (taken me +30 GB on my SSD :P )
I'm using the Linux bash on Windows to start my Meteor app and it's working fine for the moment, but I don't think it's the best solution for various reasons.

@trinicoder

This comment has been minimized.

trinicoder commented May 7, 2018

Same issue here, after the update is when it seems to be crashing.

@thewebkid

This comment has been minimized.

thewebkid commented May 8, 2018

Slightly different error (Meteor 1.6.0.1), but I am sure it is related to windows update. Burned 2 dev days flattening and reinstalling dev environments because I couldn't find anything online about this issue:

W20180507-19:35:11.809(-7)? (STDERR) Error: EPERM: operation not permitted, stat 'C:\src\Analytics-Insights\app\.meteor\local\build\programs\server\node_modules'
W20180507-19:35:11.809(-7)? (STDERR)     at Object.realpathSync (fs.js:1670:17)
W20180507-19:35:11.809(-7)? (STDERR)     at toRealPath (module.js:156:13)
W20180507-19:35:11.809(-7)? (STDERR)     at tryFile (module.js:152:22)
W20180507-19:35:11.809(-7)? (STDERR)     at tryExtensions (module.js:164:22)
W20180507-19:35:11.809(-7)? (STDERR)     at Function.Module._findPath (module.js:217:20)
W20180507-19:35:11.810(-7)? (STDERR)     at Function.Module._resolveFilename (module.js:534:25)
W20180507-19:35:11.810(-7)? (STDERR)     at Function.Module._load (module.js:466:25)
W20180507-19:35:11.810(-7)? (STDERR)     at Module.require (module.js:579:17)
W20180507-19:35:11.810(-7)? (STDERR)     at require (internal/module.js:11:18)
W20180507-19:35:11.810(-7)? (STDERR)     at Object.require (C:\src\Analytics-Insights\app\.meteor\local\build\programs\server\boot.js:283:20)
@Rhywden

This comment has been minimized.

Contributor

Rhywden commented May 8, 2018

In the meantime, here's a workaround on how to keep your files in Windows, using the Linux Subsystem:
https://forums.meteor.com/t/workaround-for-windows-10-users-with-current-problems-fibers-not-found/43574

@lhz516

This comment has been minimized.

lhz516 commented May 11, 2018

Same thing for 1.7-rc.6

@gc87

This comment has been minimized.

gc87 commented May 11, 2018

I have the same issue,I'm use choco to install meteor1.6.1.1 on Windows 10 1803.

@zodern

This comment has been minimized.

Contributor

zodern commented May 12, 2018

Meteor 1.5 and older work, so I ran a git bisect today. The cause is eded323. Windows no longer throws an error when creating a symlink for a directory, so eded323#diff-075e9c46ed726aa6f6c8ec1288336f6dR744 is never run.

@benjamn

This comment has been minimized.

Member

benjamn commented May 12, 2018

@zodern Are you saying that Windows fails to create the symlink, but doesn't throw any kind of error to report the failure?

@zodern

This comment has been minimized.

Contributor

zodern commented May 12, 2018

The symlink is created, but it doesn't work correctly since the type is file instead of junction.

@marcoroche

This comment has been minimized.

marcoroche commented May 25, 2018

Same issue and don't have enough space to install Linux.

Strangely enough, I can run meteor without admin privileges but can't run Cordova without admin privileges.

I can work but I need to act as MacGiver.

@NitroBAY

This comment has been minimized.

NitroBAY commented May 25, 2018

@thewebkid I have the same issue than you, what is going on RN ?? 2 weeks later unfixed ? Why ? Have Meteor's team tracked down the issue yet ? I'm confused that windows support broke with not that much noise even though how widely Windows and Meteor are used ??

@lanmower

This comment has been minimized.

lanmower commented May 26, 2018

I'm confused too, this makes android development impossible on windows.

@lanmower

This comment has been minimized.

lanmower commented May 26, 2018

This is so critical I don't understand why its not being fixed.

@benjamn

This comment has been minimized.

Member

benjamn commented May 26, 2018

If you don't want to update to the Meteor 1.7 release candidates yet, please try running

meteor update --release 1.6.1.2-rc.0

to install a preview of Meteor 1.6.1.2, which was created specifically to solve this problem.

@benjamn benjamn added this to the Release 1.6.1.2 milestone May 26, 2018

@marcoroche

This comment has been minimized.

marcoroche commented May 31, 2018

Every time we do an update we still have to deal with Error: Cannot find module 'dezalgo'

It could be nice to include this command too in your future patch

meteor npm i -g write-file-atomic path-is-inside async-some dezalgo

With the 2 patches it works, I can carry on debugging without installing Linux.

@lanmower

This comment has been minimized.

lanmower commented May 31, 2018

@Kupuyc

This comment has been minimized.

Kupuyc commented Jun 3, 2018

Same issue.

@benjamn
I tried

meteor update --release 1.6.1.2-rc.0
meteor update --release 1.6.1.2

and in both cases got error "unknown release". Meteor installed by choco and "choco upgrade meteor" says "meteor v0.0.2 is the latest version available based on your source(s)". How to upgrade to 1.6.1.2?

update:
I did it. Looks like environment variable METEOR_OFFLINE_CATALOG interferes update.

@thewebkid

This comment has been minimized.

thewebkid commented Jun 3, 2018

I can say in all honesty this was a factor in me quitting my job - and meteor along with it. Bye bye fibers, blaze, tracker.autorun, slow to no windows compile time...

Start my new job monday (c:

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment