New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update Twitter Bootstrap to 2.1.0 #293

Closed
wants to merge 1 commit into
base: devel
from

Conversation

Projects
None yet
10 participants
@alansikora

alansikora commented Aug 22, 2012

The files:

css/bootstrap.js
css/bootstrap.css
css/bootstrap-response.css
img/glyphicons-halflings-white.png
img/glyphicons-halflings.png
have been replaced with the newer 2.1.0 files.

The file css/bootstrap-override.css is still the same.

Everything is working well, the change on Twitter Bootstrap is not big enough to break anything.

@stephentcannon

This comment has been minimized.

stephentcannon commented Aug 23, 2012

bootstrap...baby bootstrap! bootstrap...baby bootstrap! +++ from me, my project depends on bootstrap

@sra

This comment has been minimized.

sra commented Aug 23, 2012

+1

@possibilities

This comment has been minimized.

Contributor

possibilities commented Aug 23, 2012

p.s. i'm gonna get bootstrap 2.1.0 on atmosphere tonight. my plan is to have 3 packages:

  1. bootstrap-css (css only, no js)
  2. bootstrap-js (depends on boostrap-css, includes the bootrap js, eventually will be renamed bootstrap when atmosphere can override core packages, i.e. soon)
  3. bootstrap-reactive (also depneds on bootstrap-css but includes reactive equivalents for twitter's js)

Check tomorrow for 1 & 2, not sure when I get to 3, could use some help.

I'm going to package these in a way that it'll come with a shell script that will aid in keeping up with future versions of bootstrap.

-Mike

@Multiply

This comment has been minimized.

Multiply commented Aug 23, 2012

I want the latest Bootstrap in Meteor in some way. Be it Atmosphere, or in core, I don't mind.
If it stays in core, it only makes sense to update it however.

And can't wait till you're done with that, @possibilities

@alansikora

This comment has been minimized.

alansikora commented Aug 23, 2012

Good to know @possibilities, that's nice.

@inhji

This comment has been minimized.

inhji commented Aug 23, 2012

+1

@sputnick

This comment has been minimized.

sputnick commented Aug 23, 2012

Update!

@crapthings

This comment has been minimized.

crapthings commented Aug 24, 2012

+1 and +1 for jquery 1.8.0

@possibilities

This comment has been minimized.

Contributor

possibilities commented Aug 24, 2012

All my plans were changed when I saw @lvbreda 's less based bootstrap package: https://github.com/lvbreda/meteor_bootstrapless

Working w/ him now to get it working smoothly w/ Atmosphere...

@possibilities

This comment has been minimized.

Contributor

possibilities commented Aug 24, 2012

Done! v2.0.4 or v2.1.0 are published. On Atmosphere the package is called bootstrap.less Awesome work by @lvbreda!

P.s. sorry if I hijacked this thread, I'll disappear from here now.

@alansikora

This comment has been minimized.

alansikora commented Sep 1, 2012

Is this going to get merged?

@TomWij

This comment has been minimized.

Contributor

TomWij commented Sep 2, 2012

@alansikora: Meteor would benefit either a person that maintains packages (raises hand) or merge in Atmosphere and make it more official / core. Atmosphere should work fine and I think we should all get used to that way of managing packages (looks at myself)...

@alansikora

This comment has been minimized.

alansikora commented Sep 3, 2012

Hm, is Atmosphere/Meteorite the official package manager?

@TomWij

This comment has been minimized.

Contributor

TomWij commented Sep 3, 2012

No, it's written by possibilities and intends to be a live update-able database so we don't have to do PRs anymore.

@n1mmy

This comment has been minimized.

Member

n1mmy commented Sep 7, 2012

@alansikora Thanks! This looks good. Sorry for the delay getting to it.

Can you please update to 2.1.1 make a new PR based on a recent devel (post 0.4.0)? I'll make sure it goes in 0.4.1.

@n1mmy

This comment has been minimized.

Member

n1mmy commented Sep 17, 2012

Bootstrap 2.1.1 in 2c62b1d

@n1mmy n1mmy closed this Sep 17, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment