Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Raise min required django version to 1.4.2

Has a some nice helpers for 2 to 3 transition, namely, django.utils.six
  • Loading branch information...
commit b9dcd2216b66c7b8b49794eb5306b7bf343d3b11 1 parent f4893c6
@mfogel authored
Showing with 5 additions and 5 deletions.
  1. +4 −4 .travis.yml
  2. +1 −1  setup.py
View
8 .travis.yml
@@ -6,14 +6,14 @@ python:
env:
- DJANGO='https://github.com/django/django/tarball/stable/1.5.x' DB='postgres'
- DJANGO='https://github.com/django/django/tarball/stable/1.5.x' DB='sqlite'
- - DJANGO='django>=1.4,<1.5' DB='postgres'
- - DJANGO='django>=1.4,<1.5' DB='sqlite'
+ - DJANGO='django>=1.4.2,<1.5' DB='postgres'
+ - DJANGO='django>=1.4.2,<1.5' DB='sqlite'
matrix:
exclude: # python 3 support only for django>=1.5
- python: 3.2
- env: DJANGO='django>=1.4,<1.5' DB='postgres'
+ env: DJANGO='django>=1.4.2,<1.5' DB='postgres'
- python: 3.2
- env: DJANGO='django>=1.4,<1.5' DB='sqlite'
+ env: DJANGO='django>=1.4.2,<1.5' DB='sqlite'
before_install:
- export PIP_USE_MIRRORS=true
install:
View
2  setup.py
@@ -35,7 +35,7 @@ def find_version(*file_paths):
packages=[
'timezone_field',
],
- install_requires=['django', 'pytz'],
+ install_requires=['django>=1.4.2', 'pytz'],
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Web Environment',
Please sign in to comment.
Something went wrong with that request. Please try again.