New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Metroid Zero Mission: freezes at the endgame cutscene #1012

Closed
mrachinskiy opened this Issue Mar 12, 2018 · 8 comments

Comments

Projects
None yet
3 participants
@mrachinskiy

mrachinskiy commented Mar 12, 2018

Game freezes in certain point of endgame cutscene (when ship starts to blow up). But issue is not presented in older releases.

Broken: d22315c dev build and 0.6.1 release.
Works: 0.5.2 release.

Save state for 0.6.1 and later
Save state for 0.5.2

Reproduce issue:

  1. Use 0.6.1 release or devbuild (d22315c)
  2. Load save state
  3. Unpause the game
  4. Board escape pod to the right
  5. Wait for cutscene to freeze
@Cibomatto2002

This comment has been minimized.

Show comment
Hide comment
@Cibomatto2002

Cibomatto2002 Mar 13, 2018

Download mGBA-build-2018-03-11-win32-5047-d22315cba5fb7d8ec6f9b2ae70cf69ecdbde9a88 still happens.

Cibomatto2002 commented Mar 13, 2018

Download mGBA-build-2018-03-11-win32-5047-d22315cba5fb7d8ec6f9b2ae70cf69ecdbde9a88 still happens.

@endrift

This comment has been minimized.

Show comment
Hide comment
@endrift

endrift Mar 18, 2018

Member

Is this broken in 0.6.0 too?

E] Confirmed broken in 0.6.0 too.

Member

endrift commented Mar 18, 2018

Is this broken in 0.6.0 too?

E] Confirmed broken in 0.6.0 too.

@endrift

This comment has been minimized.

Show comment
Hide comment
@endrift

endrift Mar 27, 2018

Member

Regressed during the mTiming cutover (after e423cd4 but before 9aa6d8f). Seems to be related to either timers or DMAs.

Member

endrift commented Mar 27, 2018

Regressed during the mTiming cutover (after e423cd4 but before 9aa6d8f). Seems to be related to either timers or DMAs.

@endrift endrift closed this in fc53fc9 Mar 28, 2018

@endrift

This comment has been minimized.

Show comment
Hide comment
@endrift

endrift Mar 28, 2018

Member

I'm not 100% sure this fix actually fixes it, but in my testing it seemed to. Let me know if it doesn't and I'll reopen the bug.

Member

endrift commented Mar 28, 2018

I'm not 100% sure this fix actually fixes it, but in my testing it seemed to. Let me know if it doesn't and I'll reopen the bug.

@mrachinskiy

This comment has been minimized.

Show comment
Hide comment
@mrachinskiy

mrachinskiy Mar 28, 2018

Tested fc53fc9, no freezes in the cutscene. Thank you!

mrachinskiy commented Mar 28, 2018

Tested fc53fc9, no freezes in the cutscene. Thank you!

@endrift

This comment has been minimized.

Show comment
Hide comment
@endrift

endrift May 26, 2018

Member

My fix for this broke a bunch of other stuff unfortunately.

Member

endrift commented May 26, 2018

My fix for this broke a bunch of other stuff unfortunately.

@endrift endrift modified the milestones: mGBA 0.6.2, mGBA 0.7.0 Sep 16, 2018

@endrift

This comment has been minimized.

Show comment
Hide comment
@endrift

endrift Sep 16, 2018

Member

Does this reproduce on latest? The 0.6.1 state freezes but the 0.5.2 state works, and playing through normally worked on my one attempt.

Member

endrift commented Sep 16, 2018

Does this reproduce on latest? The 0.6.1 state freezes but the 0.5.2 state works, and playing through normally worked on my one attempt.

@mrachinskiy

This comment has been minimized.

Show comment
Hide comment
@mrachinskiy

mrachinskiy Sep 18, 2018

I have tested on 108b0fc dev build, and I got results similar to yours: 0.6.1 state freezes, 0.5.2 state works, and loading from in-game save works (which I assume would be equal to a normal playthrough).
Looks like it has been fixed!

mrachinskiy commented Sep 18, 2018

I have tested on 108b0fc dev build, and I got results similar to yours: 0.6.1 state freezes, 0.5.2 state works, and loading from in-game save works (which I assume would be equal to a normal playthrough).
Looks like it has been fixed!

@endrift endrift closed this Sep 18, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment