Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Quick save states sometimes get corrupted #1293

Closed
themalu866 opened this issue Feb 1, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@themalu866
Copy link

commented Feb 1, 2019

Okay, so I noticed that sometimes when I quick save (with shift+F1 or F2 or F3...) GB or GBC games and then try to load them, the save file doesn't work.
Sometimes even with a early save that works, I save over it and doesn't load anymore, not even by pressing F10 and choosing the save file.
This doesn't seems to happen when I play GBA games but I'm not sure about that, probably have to check more.
Maybe this has been overlooked because it doesn't always happens and other people don't save as much but I pretty sure it's a glitch, I've never seen any other emulator where this happens.
I use on Windows 7 and no, I didn't mess with the roms names or saves and neither with the kind of archives they are, it's just something that happens randomly.

Super Mario Land.zip

Goemon.zip

@endrift

This comment has been minimized.

Copy link
Member

commented Feb 1, 2019

Please attach a corrupted save state.

@themalu866

This comment has been minimized.

Copy link
Author

commented Feb 1, 2019

@endrift

This comment has been minimized.

Copy link
Member

commented Feb 12, 2019

Good news: the states aren't corrupted, there was a bug in loading them. That's fixed now so the dev builds will be able to load them again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.