Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OpenGL Enhancement Renderer fails if all layers are off. #2260

Closed
Lokathor opened this issue Jul 28, 2021 · 1 comment
Closed

OpenGL Enhancement Renderer fails if all layers are off. #2260

Lokathor opened this issue Jul 28, 2021 · 1 comment
Labels
hardware:2D platform:GBA
Milestone

Comments

@Lokathor
Copy link

Lokathor commented Jul 28, 2021

Test Rom: demo.zip

This starts up, turns off the Forced Blank bit, and then write pink to the backdrop color palette slot.

This should make pink appear on the whole screen.

However, if the OpenGL display driver is used and the OpenGL enhancement renderer is selected, then the screen ends up all white instead, as if the forced blank bit was still on.

@endrift
Copy link
Member

endrift commented Jul 28, 2021

This seems to work fine...if the BIOS intro plays. Otherwise I'm able to reproduce as described.

@endrift endrift added hardware:2D platform:GBA labels Jul 28, 2021
@endrift endrift added this to the mGBA 0.9.3 milestone Jul 28, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
hardware:2D platform:GBA
Projects
None yet
Development

No branches or pull requests

2 participants