mGBA Vita fails to save games (or fails to load save files) #441

Closed
brainard52 opened this Issue Oct 14, 2016 · 9 comments

Comments

Projects
None yet
5 participants

If I save a game on version 0.5.0 and close the emulator, it starts the next time as though it never saved to begin with. The .sav file gets created but I'm not sure whether it actually wrote anything to it. I'm not sure what else I need to provide.

Owner

endrift commented Oct 14, 2016

  • Please don't use 0.5.0. 0.5.1 is out and provides many critical bugfixes.
  • What games are you playing that are causing this issue?
  • Are you exiting the game using the menu (triangle > exit) or are you tearing the page off?
  • Please upload the sav file and tell me what game it's for.

endrift added this to the 0.5.2 milestone Oct 14, 2016

brainard52 commented Oct 14, 2016 edited

I just tested on 0.5.1 with Final Fantasy Tactics Advanced and Dragon Warrior Monsters (GB). It seems to be working. I still have the 0.5.0 vpk if you still want me to test on there.

For reference, I experienced the issue on 0.5.0 with both of the games I mentioned. I went to the emulator menu to exit for DWM but it's been a while since I tried with FFT so I don't remember what I did.

Asuza commented Oct 28, 2016

I'm having this same issue. I downloaded version 0.5.1, installed it, and added Castlevania: Circle of the Moon (E)(Eurasia). I played for a while, saved a few times (within the game), I then exited the game using the "Exit game" option in the menu. When I came back to Castlevania later, a .sav file had been created for it, but my file in the game was not there.

Then, I tried the same process with Mother 3. For this game, I had an existing .sav file from an old version of mGBA (pre-5.0) and the save file loaded without issue. But, when I saved the game and exited, then reloaded the game, it did not have the new save. The .sav file is still loading fine, so it didn't break the existing save, but it did not update the file at all. Oddly, VitaShell shows a new date for the save file, so it was touched in some way.

endrift added the port:wii label Oct 28, 2016

Owner

endrift commented Oct 28, 2016

I've had people report this on the Wii, too.

I'll need to look into it again, but were you using savestates at the time?

Asuza commented Oct 28, 2016

@endrift I didn't use save states for Castlevania. I did for Mother 3, and those seemed to work fine.

@endrift I remember using save states for Minish Cap and having them fail on me. I was introducing my sister to the game when it happened and she had played for a good hour and a half. She didn't play after that.

rraab8 commented Dec 10, 2016

I'm having the same problem but on the Microsoft Windows version for the game Super Mario Advance 2
Other games I've tried are saving probably.
I've been trying new nightlies as they come out to see if the issue is resolved.

@endrift endrift modified the milestone: 0.5.2, 0.6.0 Dec 31, 2016

ml- commented Jan 11, 2017

Reproduce bad save on the Vita

Game: Pokemon - Version Rouge Feu (France) ( md5: b8663b80eef5a1e9b41b683aa1234902 ) No-Intro

Steps:

  1. Start game
  2. Load state (1)
  3. Wait 2-3 seconds, game will save
  4. Reset the game after it saved (you don't want to sit through 10 minutes of credits)
  5. See if game created a valid savegame file.

On the PC a valid savegame should be created and look like this:
poke-0

On the Vita a .sav file is created but won't be shown ingame. This is an issue with the created savegame, not an issue with loading it because you can place a valid savegame on your Vita and it'll work.

Pokemon - Version Rouge Feu (France).ss1.zip

endrift closed this in dc317e9 Jan 31, 2017

Owner

endrift commented Jan 31, 2017 edited

This SHOULD be fixed now. Please test heavily with the upcoming nightly (which will be released in about 5 hours) and let me know if there are still any issues present regarding saving.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment