Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Shift key not displayed correctly in Keyboard settings #525

Closed
Prof9 opened this issue Feb 14, 2017 · 4 comments
Closed

Shift key not displayed correctly in Keyboard settings #525

Prof9 opened this issue Feb 14, 2017 · 4 comments

Comments

@Prof9
Copy link
Contributor

@Prof9 Prof9 commented Feb 14, 2017

See image below, where Right Shift has been assigned to the Select button. It shows up as garbage in the settings, but it does work correctly in-game (as well as Left Shift). Using the latest nightly (17cfee0) on Windows 10 x64.

http://i.imgur.com/pbcmQaX.png

@endrift
Copy link
Member

@endrift endrift commented Feb 14, 2017

I'm under the impression that this is a Qt bug. I've seen it before.

@obskyr
Copy link

@obskyr obskyr commented May 19, 2017

Can confirm! Interestingly enough, if you press shift together with another key (or within a short timeframe after pressing another key), it shows up just fine. Here I've juggled the interface enough to set Select to shift + left mouse (which just displays as Shift+), and Start to shift + M.

Settings

Incidentally, it turns out entering key combinations is possible although incredibly (incredibly) finicky.

@endrift
Copy link
Member

@endrift endrift commented May 19, 2017

For what it's worth, this entire interface is getting replaced when the input revamp is done. An early version of it was merged into medusa but it's...rather early still and buggy. It will probably need a full redesign, even.

@endrift endrift added the port:Qt label May 19, 2017
@endrift endrift added this to the 0.7.0 milestone Jul 9, 2017
@endrift endrift added the os:Windows label Jul 9, 2017
@endrift endrift modified the milestones: mGBA 0.7.0, mGBA 0.7.1 Oct 16, 2018
@endrift endrift modified the milestones: mGBA 0.7.1, mGBA 0.7.2 Feb 25, 2019
@endrift endrift modified the milestones: mGBA 0.7.2, mGBA 0.8.0 May 25, 2019
@endrift endrift modified the milestones: mGBA 0.8.0, mGBA 0.9.0 Jan 22, 2020
@endrift
Copy link
Member

@endrift endrift commented Feb 15, 2020

Turns out this is a bug in Qt itself. I'll have to work around it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.