Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Buggy sound in GB/GBC #768

Closed
sergiobenrocha2 opened this Issue Jun 30, 2017 · 5 comments

Comments

Projects
None yet
2 participants
Contributor

sergiobenrocha2 commented Jun 30, 2017 edited

1 - Load a GBA game (sound is fine)
2 - Load a GB/GBC game, you'll notice buggy sound / static noise in every GB/GBC game you load now
3 - Try record it in Record Output, it'll not get the buggy sound

If you first load a GB/GBC game, it'll be fine

Xubuntu 17.04

Owner

endrift commented Jun 30, 2017

I can't trivially reproduce this on macOS. Can you be more specific, e.g. which GBA and GB games? Or are you having it with just any?

Contributor

sergiobenrocha2 commented Jun 30, 2017

No, the noise is only in GB/GBC games. You can load a GBA game again, no noise

@endrift endrift modified the milestone: 0.6.0 Jun 30, 2017

Contributor

sergiobenrocha2 commented Jul 7, 2017 edited

You now have to:

1 - Load a GBA game (sound is fine)
2 - Load a GB/GBC game
3 - Load a GBA game again
4 - Load a GB/GBC game, you'll notice the bug

You'll notice better with Pokemon Pinball (GBC)

Owner

endrift commented Jul 8, 2017

Still can't reproduce on macOS. Will try again on Linux before releasing beta 2.

@endrift endrift closed this in 6916009 Jul 9, 2017

Owner

endrift commented Jul 9, 2017

Looks like it's an SDL bug. I had to work around it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment