Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test suite fails to run on Debian Hurd #116

Closed
hpreusse opened this issue Jul 26, 2019 · 3 comments

Comments

@hpreusse
Copy link

commented Jul 26, 2019

We're trying to build the source code on Debian Hurd. Building the binary runs fine, but in the test suite afterwards a test fails. The test suite log is attached.

test-suite.log

@mgieseki

This comment has been minimized.

Copy link
Owner

commented Jul 26, 2019

That's obliviously a rounding issue. Could you check if this patch fixes the test?

@mgieseki mgieseki self-assigned this Jul 26, 2019

@hpreusse

This comment has been minimized.

Copy link
Author

commented Jul 26, 2019

I can confirm that the patch solves the issue on Hurd (I did not test any other arch). Is that a patch I can apply to our source package generally or does Hurd need a specific solution?

@mgieseki

This comment has been minimized.

Copy link
Owner

commented Jul 26, 2019

Thanks for the confirmation. It's a general patch I'm going to commit to the dvisvgm sources shortly. Especially, it shouldn't negatively affect other archs but just avoid the unexpected rounding issue you experienced.

@mgieseki mgieseki added the bug label Jul 26, 2019

@mgieseki mgieseki closed this in 56e0cf1 Jul 27, 2019

@mgieseki mgieseki added this to the 2.7.4 milestone Jul 27, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.