.NET Core RC1 not supported #159

Closed
wjdavis5 opened this Issue Jun 9, 2016 · 6 comments

Comments

Projects
None yet
6 participants
@wjdavis5

wjdavis5 commented Jun 9, 2016

It appears that the project supports .NET Core 4.5 (is that even a thing?) But does support .NET Core RC1

image

Errors in C:\users\willi\documents\visual studio 2015\Projects\ConsoleApp1\src\ConsoleApp1\project.json

Package protobuf-net 2.0.0.668 is not compatible with netcoreapp1.0 (.NETCoreApp,Version=v1.0). Package protobuf-net 

2.0.0.668 supports:
- net20 (.NETFramework,Version=v2.0)
- net20-cf (.NETFramework,Version=v2.0,Profile=CompactFramework)
- net30 (.NETFramework,Version=v3.0)
- net35 (.NETFramework,Version=v3.5)
- net35-cf (.NETFramework,Version=v3.5,Profile=CompactFramework)
- net40 (.NETFramework,Version=v4.0)
- net40-cf (.NETFramework,Version=v4.0,Profile=CompactFramework)
- netcore45 (.NETCore,Version=v4.5)
- portable-net40+sl4+win8+wp7 (.NETPortable,Version=v0.0,Profile=Profile2)
- sl3-wp (Silverlight,Version=v3.0,Profile=WindowsPhone)
- sl4 (Silverlight,Version=v4.0)
- sl4-wp71 (Silverlight,Version=v4.0,Profile=WindowsPhone71)
- wp8 (WindowsPhone,Version=v8.0)
One or more packages are incompatible with .NETCoreApp,Version=v1.0.

@mgravell

This comment has been minimized.

Show comment
Hide comment
@mgravell

mgravell Jun 9, 2016

Owner

I have not yet updated it to current RCs.

On Thu, 9 Jun 2016 10:50 William Davis, notifications@github.com wrote:

It appears that the project supports .NET Core 4.5 (is that even a thing?)
But does support .NET Core RC1

[image: image]
https://cloud.githubusercontent.com/assets/2580575/15925646/f9a27ea6-2e05-11e6-9745-1acdaa04714b.png

Errors in C:\users\willi\documents\visual studio
2015\Projects\ConsoleApp1\src\ConsoleApp1\project.json

Package protobuf-net 2.0.0.668 is not compatible with netcoreapp1.0 (.NETCoreApp,Version=v1.0). Package protobuf-net

2.0.0.668 supports:

  • net20 (.NETFramework,Version=v2.0)
  • net20-cf (.NETFramework,Version=v2.0,Profile=CompactFramework)
  • net30 (.NETFramework,Version=v3.0)
  • net35 (.NETFramework,Version=v3.5)
  • net35-cf (.NETFramework,Version=v3.5,Profile=CompactFramework)
  • net40 (.NETFramework,Version=v4.0)
  • net40-cf (.NETFramework,Version=v4.0,Profile=CompactFramework)
    - netcore45 (.NETCore,Version=v4.5)
  • portable-net40+sl4+win8+wp7 (.NETPortable,Version=v0.0,Profile=Profile2)
  • sl3-wp (Silverlight,Version=v3.0,Profile=WindowsPhone)
  • sl4 (Silverlight,Version=v4.0)
  • sl4-wp71 (Silverlight,Version=v4.0,Profile=WindowsPhone71)
  • wp8 (WindowsPhone,Version=v8.0)
    One or more packages are incompatible with .NETCoreApp,Version=v1.0.


You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub
#159, or mute the thread
https://github.com/notifications/unsubscribe/AABDsNy0YQqiae1rDG98J0eyj8ONvOqzks5qJ-HfgaJpZM4IxzXo
.

Owner

mgravell commented Jun 9, 2016

I have not yet updated it to current RCs.

On Thu, 9 Jun 2016 10:50 William Davis, notifications@github.com wrote:

It appears that the project supports .NET Core 4.5 (is that even a thing?)
But does support .NET Core RC1

[image: image]
https://cloud.githubusercontent.com/assets/2580575/15925646/f9a27ea6-2e05-11e6-9745-1acdaa04714b.png

Errors in C:\users\willi\documents\visual studio
2015\Projects\ConsoleApp1\src\ConsoleApp1\project.json

Package protobuf-net 2.0.0.668 is not compatible with netcoreapp1.0 (.NETCoreApp,Version=v1.0). Package protobuf-net

2.0.0.668 supports:

  • net20 (.NETFramework,Version=v2.0)
  • net20-cf (.NETFramework,Version=v2.0,Profile=CompactFramework)
  • net30 (.NETFramework,Version=v3.0)
  • net35 (.NETFramework,Version=v3.5)
  • net35-cf (.NETFramework,Version=v3.5,Profile=CompactFramework)
  • net40 (.NETFramework,Version=v4.0)
  • net40-cf (.NETFramework,Version=v4.0,Profile=CompactFramework)
    - netcore45 (.NETCore,Version=v4.5)
  • portable-net40+sl4+win8+wp7 (.NETPortable,Version=v0.0,Profile=Profile2)
  • sl3-wp (Silverlight,Version=v3.0,Profile=WindowsPhone)
  • sl4 (Silverlight,Version=v4.0)
  • sl4-wp71 (Silverlight,Version=v4.0,Profile=WindowsPhone71)
  • wp8 (WindowsPhone,Version=v8.0)
    One or more packages are incompatible with .NETCoreApp,Version=v1.0.


You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub
#159, or mute the thread
https://github.com/notifications/unsubscribe/AABDsNy0YQqiae1rDG98J0eyj8ONvOqzks5qJ-HfgaJpZM4IxzXo
.

@pantonis

This comment has been minimized.

Show comment
Hide comment
@pantonis

pantonis Jul 14, 2016

+1 Need urgently

Thanks

+1 Need urgently

Thanks

@cemremengu

This comment has been minimized.

Show comment
Hide comment
@cemremengu

cemremengu Oct 18, 2016

Any ETA on this one ?

Any ETA on this one ?

@mcmillab

This comment has been minimized.

Show comment
Hide comment
@mcmillab

mcmillab Mar 22, 2017

I don't understand - so we can't use Protobuf.Net on .Net Core at the moment?

I don't understand - so we can't use Protobuf.Net on .Net Core at the moment?

@li-keli

This comment has been minimized.

Show comment
Hide comment
@li-keli

li-keli Apr 14, 2017

now , .Net Core can use Protobuf.Net ?

li-keli commented Apr 14, 2017

now , .Net Core can use Protobuf.Net ?

@wjdavis5

This comment has been minimized.

Show comment
Hide comment

This is supported now.

https://www.nuget.org/packages/protobuf-net/

@wjdavis5 wjdavis5 closed this Mar 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment