Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
194 lines (184 sloc) 9.38 KB
<!DOCTYPE html>
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<title>rails 3 1 example gemfile &#183; RailsApps</title>
<link href="https://plus.google.com/u/0/b/117374718581973393536/117374718581973393536/posts/" rel="publisher" />
<link rel="stylesheet" href="http://railsapps.github.com/css/bootstrap.css" type="text/css" charset="utf-8" />
<link rel="stylesheet" href="http://railsapps.github.com/css/screen.css" type="text/css" charset="utf-8" />
<link rel="stylesheet" href="http://railsapps.github.com/css/gollum.css" type="text/css" charset="utf-8" />
<link rel="stylesheet" href="http://railsapps.github.com/css/site.css" type="text/css" charset="utf-8" />
<link rel="stylesheet" href="http://railsapps.github.com/css/syntax.css" type="text/css" charset="utf-8" />
<script src="http://code.jquery.com/jquery-1.6.min.js" type="text/javascript"></script>
<script src="http://railsapps.github.com/javascript/jquery.text_selection-1.0.0.min.js" type="text/javascript"></script>
<script src="http://railsapps.github.com/javascript/jquery.previewable_comment_form.js" type="text/javascript"></script>
<script src="http://railsapps.github.com/javascript/jquery.tabs.js" type="text/javascript"></script>
<script src="http://railsapps.github.com/javascript/gollum.js" type="text/javascript"></script>
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-5109366-14']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
</head>
<body>
<div class="navbar navbar-fixed-top">
<div class="navbar-inner">
<div class="container">
<a href="http://railsapps.github.com/" class="brand">RailsApps Project</a>
<ul class="pull-right nav">
<li><a href="http://blog.railsapps.org/" class="twitter">Blog</a></li>
<li><a href="http://twitter.com/rails_apps" class="twitter">Twitter</a></li>
<li><a href="https://plus.google.com/117374718581973393536" class="google">Google +</a></li>
<li><a href="https://github.com/RailsApps" class="github">GitHub Repository</a></li>
</ul>
</div>
</div>
</div>
<div class="container">
<div class="content wikistyle gollum textile">
<h1>Example Gemfile for Rails 3.1.0</h1>
<p>Here are Gemfiles for the example apps in the <a href="http://railsapps.github.com/">Rails Apps</a> repository.</p>
<p>For the newer Rails 3.2 release, see the <a class="internal present" href="/rails-3-2-example-gemfile.html">Example Rails 3.2 Gemfile</a>.</p>
<h2>Background</h2>
<p>For background, see <a href="http://railsapps.github.com/managing-rails-versions-gems.html">Managing Rails Versions and Gems</a>.</p>
<p>Also see instructions for <a class="internal present" href="/installing-rails-3-1.html">Installing Rails 3.1</a>.</p>
<p>The example apps have been tested with this configuration:</p>
<ul>
<li>Ruby 1.9.2</li>
<li>RubyGems 1.8.10</li>
<li>Rails 3.1.0</li>
<li>Rake 0.9.2</li>
</ul><h2>Required Gems</h2>
<p>The example applications use the following gems.</p>
<ul>
<li><a href="http://rubygems.org/gems/rails">rails</a></li>
<li><a href="http://rubygems.org/gems/rspec-rails">rspec-rails</a></li>
<li><a href="http://rubygems.org/gems/database_cleaner">database_cleaner</a></li>
<li><a href="http://rubygems.org/gems/factory_girl_rails">factory_girl_rails</a></li>
<li><a href="http://rubygems.org/gems/cucumber-rails">cucumber-rails</a></li>
<li><a href="http://rubygems.org/gems/capybara">capybara</a></li>
</ul><p>Two of the example apps use the <a href="http://mongoid.org/">Mongoid</a> gem for access to a MongoDB datastore.</p>
<ul>
<li><a href="http://rubygems.org/gems/mongoid">mongoid</a></li>
</ul><p>Two of the example apps use <a href="http://github.com/plataformatec/devise">Devise</a> for authentication.</p>
<ul>
<li><a href="http://rubygems.org/gems/devise">devise</a></li>
</ul><p>One of the example apps uses <a href="https://github.com/intridea/omniauth">OmniAuth</a> for authentication.</p>
<ul>
<li><a href="http://rubygems.org/gems/omniauth">omniauth</a></li>
</ul><p>I recommend checking for the newest versions of these gems before proceeding.</p>
<h4>Ubuntu Linux</h4>
<p>For Rails 3.1, a JavaScript runtime is needed for Linux Ubuntu. It is not needed for Mac OS X or Windows.</p>
<ul>
<li><a href="http://rubygems.org/gems/therubyracer">therubyracer</a></li>
</ul><p>Add this to your Gemfile:</p>
<pre>
gem 'therubyracer', '&gt;= 0.9.2'
</pre>
<h2>Example Gemfiles</h2>
<p>For the example apps built with Rails 3.1.0, I recommend that you use the following gems and specify versions optimistically (using the <code>&gt;=</code> operator).</p>
<p>The example apps have been tested with the indicated versions.</p>
<h4><a href="https://github.com/RailsApps/rails3-devise-rspec-cucumber">rails3-devise-rspec-cucumber</a></h4>
<pre>
source 'http://rubygems.org'
gem 'rails', '3.1.0'
gem 'sqlite3'
group :assets do
gem 'sass-rails', " ~&gt; 3.1.0"
gem 'coffee-rails', "~&gt; 3.1.0"
gem 'uglifier'
end
gem 'jquery-rails'
gem "rspec-rails", "&gt;= 2.6.1", :group =&gt; [:development, :test]
gem "factory_girl_rails", "&gt;= 1.1.0", :group =&gt; :test
gem "cucumber-rails", "&gt;= 1.0.2", :group =&gt; :test
gem "capybara", "&gt;= 1.0.1", :group =&gt; :test
gem "database_cleaner", "&gt;= 0.6.7", :group =&gt; :test
gem "launchy", "&gt;= 2.0.5", :group =&gt; :test
gem "devise", "&gt;= 1.4.4"
</pre>
<h4><a href="https://github.com/RailsApps/rails3-mongoid-devise">rails3-mongoid-devise</a></h4>
<pre>
source 'http://rubygems.org'
gem 'rails', '3.1.0'
group :assets do
gem 'sass-rails', " ~&gt; 3.1.0"
gem 'coffee-rails', "~&gt; 3.1.0"
gem 'uglifier'
end
gem 'jquery-rails'
gem "rspec-rails", "&gt;= 2.6.1", :group =&gt; [:development, :test]
gem "database_cleaner", "&gt;= 0.6.7", :group =&gt; :test
gem "mongoid-rspec", "&gt;= 1.4.4", :group =&gt; :test
gem "factory_girl_rails", "&gt;= 1.1.0", :group =&gt; :test
gem "cucumber-rails", "&gt;= 1.0.2", :group =&gt; :test
gem "capybara", "&gt;= 1.0.1", :group =&gt; :test
gem "launchy", "&gt;= 2.0.5", :group =&gt; :test
gem "bson_ext", "&gt;= 1.3.1"
gem "mongoid", "&gt;= 2.2.0"
gem "devise", "&gt;= 1.4.4"
</pre>
<h4><a href="https://github.com/RailsApps/rails3-mongoid-omniauth">rails3-mongoid-omniauth</a></h4>
<pre>
source 'http://rubygems.org'
gem 'rails', '3.1.0'
group :assets do
gem 'sass-rails', " ~&gt; 3.1.0"
gem 'coffee-rails', "~&gt; 3.1.0"
gem 'uglifier'
end
gem 'jquery-rails'
gem "rspec-rails", "&gt;= 2.6.1", :group =&gt; [:development, :test]
gem "database_cleaner", "&gt;= 0.6.7", :group =&gt; :test
gem "mongoid-rspec", "&gt;= 1.4.4", :group =&gt; :test
gem "factory_girl_rails", "&gt;= 1.1.0", :group =&gt; :test
gem "cucumber-rails", "&gt;= 1.0.2", :group =&gt; :test
gem "capybara", "&gt;= 1.0.1", :group =&gt; :test
gem "launchy", "&gt;= 2.0.5", :group =&gt; :test
gem "bson_ext", "&gt;= 1.3.1"
gem "mongoid", "&gt;= 2.2.0"
gem "omniauth", "&gt;= 0.2.6", :git =&gt; "git://github.com/intridea/omniauth.git"
</pre>
</div><!-- class="content" -->
<div class="comments">
<div class="content wikistyle gollum">
<h2>Comments and Issues</h2>
</div>
<p>Is this helpful? Please add a comment below. Your encouragement fuels the project.</p>
<p>Did you find an error? Or couldn't get something to work? For the example apps and tutorials, please create a GitHub issue in the repository for the example app. Creating a GitHub issue is the best way to make sure a problem is investigated and fixed.</p>
<div id="disqus_thread"></div>
<script type="text/javascript">
/* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
var disqus_shortname = 'railsapps'; // required: replace example with your forum shortname
/* * * DON'T EDIT BELOW THIS LINE * * */
(function() {
var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
</div><!-- class="comments" -->
<div class="footer row">
<div class="span4">
<h3>Credits</h3>
<p><a href="http://danielkehoe.com/">Daniel Kehoe</a> initiated the <a href="http://railsapps.github.com/">RailsApps Project</a>. Thanks to all the users and contributors.</p>
</div>
<div class="span4">
<h3>Wiki</h3>
<p>Corrections? Additions? You can edit this page <a href="https://github.com/RailsApps/railsapps.github.com/wiki/_pages">on the wiki</a>.</p>
</div>
<div class="span4">
<h3>Last edit</h3>
<p>by <b>Daniel Kehoe</b>, 2012-07-20 23:08:42</p>
</div>
</div>
</div>
</body>
</html>