Skip to content

Explicit YAML require for recent Ruby versions #4

Closed
wants to merge 5 commits into from

2 participants

@robsyme
robsyme commented Aug 6, 2013

Hi Michael

It seems that all of the YAML bits break on newish (v2.0.0+) versions of ruby. This should fix that (I think).

@michaelbarton
Owner
@robsyme
robsyme commented Aug 6, 2013

I didn't know that Ruby 2.0 removed the Syck implementation until I ran genomer. Easy fix though. The relevant doc is http://ruby-doc.org/stdlib-1.9.3/libdoc/yaml/rdoc/YAML.html#label-Syck

@michaelbarton
Owner

Hi Rob, I merged in your patch fine but I'm having some problems getting 1.8.7 to work with the latest version of md2man. I'll let you know when I've figured it all out.

@robsyme
robsyme commented Aug 13, 2013

No worries. I'll use my fork until you bump the version on this one.

@michaelbarton michaelbarton added a commit that referenced this pull request Aug 13, 2013
@michaelbarton Highlight md2man problem in backwards compatibility #4
Signed-off-by: Michael Barton <mail@michaelbarton.me.uk>
2c414ca
@michaelbarton michaelbarton added a commit that referenced this pull request Aug 13, 2013
@michaelbarton Merge branch 'feature/ruby-2.0.0' into release/0.1.0 #4 3aff775
@michaelbarton michaelbarton added a commit that closed this pull request Aug 13, 2013
@michaelbarton Merge branch 'release/0.1.0' closes #4
  * Genomer compatible with ruby 2.0.0 thanks to @robsyme
  * Use more secure https:// in genomer project Gemfile
  * Update all gem versions
  * Fix error where features were run from installed version
    of genomer rather than the version being developed.
06d26fb
@michaelbarton
Owner

All fixed now. Try genomer 0.1.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.