Permalink
Switch branches/tags
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
68 lines (67 sloc) 2.11 KB
{
"name": "ngx-pagination",
"version": "3.2.0",
"description": "Pagination for Angular",
"module": "dist/ngx-pagination.js",
"main": "dist/ngx-pagination.umd.js",
"types": "dist/ngx-pagination.d.ts",
"scripts": {
"clean": "rm -rf build && rm -rf dist",
"ngc": "ngc -p config/tsconfig.build.json",
"rollup:fesm": "rollup build/ngx-pagination.js -o dist/ngx-pagination.js -f es",
"rollup:umd": "rollup build/ngx-pagination.js -o dist/ngx-pagination.umd.js --f umd --name ngxPagination",
"copy-metadata": "find build/* -not -name '*.js' -exec cp -t dist {} +",
"build": "npm run clean && npm run ngc && npm run rollup:fesm && npm run rollup:umd && npm run copy-metadata",
"test": "karma start config/karma.conf.js",
"test:watch": "npm run test -- --auto-watch --no-single-run",
"publish-lib": "npm run test && npm run build"
},
"files": [
"dist"
],
"keywords": [
"angular",
"angular2",
"pagination"
],
"repository": {
"type": "git",
"url": "https://github.com/michaelbromley/ngx-pagination"
},
"bugs": {
"url": "https://github.com/michaelbromley/ngx-pagination/issues"
},
"author": "Michael Bromley <michael@michaelbromley.co.uk>",
"license": "MIT",
"devDependencies": {
"@angular/common": "4.0.2",
"@angular/compiler": "4.0.2",
"@angular/compiler-cli": "4.0.2",
"@angular/core": "4.0.2",
"@angular/platform-browser": "4.0.2",
"@angular/platform-browser-dynamic": "4.0.2",
"@types/jasmine": "2.5.41",
"@types/node": "^6.0.45",
"jasmine-core": "^2.4.1",
"json-loader": "^0.5.4",
"karma": "1.7.1",
"karma-chrome-launcher": "2.0.0",
"karma-jasmine": "1.1.0",
"karma-mocha-reporter": "^2.2.0",
"karma-phantomjs-launcher": "1.0.4",
"karma-webpack": "^2.0.3",
"marked": "^0.3.6",
"phantomjs-prebuilt": "^2.1.7",
"reflect-metadata": "0.1.10",
"rollup": "^0.50.0",
"rxjs": "^5.0.3",
"ts-loader": "^3.0.5",
"typescript": "2.4.2",
"webpack": "3.8.1",
"zone.js": "^0.8.5"
},
"peerDependencies": {
"@angular/core": ">=2.3.1",
"@angular/common": ">=2.3.1"
}
}