Browse files

Updated amp-git to use local repos, not gems.

  • Loading branch information...
1 parent 9bd1581 commit 4293240addf305a9a13fc12da5feb4cdb84d60b1 Michael Edgar committed Nov 16, 2010
View
1 amp-core/lib/amp-core.rb
@@ -1,5 +1,6 @@
puts "Loading amp-core..."
+$LOAD_PATH.unshift(File.expand_path(File.dirname(__FILE__)))
require 'amp-front'
require 'amp-core/command_ext/repository_loading'
require 'amp-core/repository/repository.rb'
View
7 amp-front/lib/amp-front.rb
@@ -1,8 +1,9 @@
module Amp
- VERSION = '0.0.1'
- VERSION_TITLE = 'Koyaanisqatsi'
-
$LOAD_PATH.unshift(File.expand_path(File.dirname(__FILE__)))
+ require 'amp-front/version'
+
+ VERSION = Amp::Front::VERSION
+ VERSION_TITLE = 'Koyaanisqatsi'
module Dispatch
autoload :Runner, 'amp-front/dispatch/runner.rb'
View
2 amp-front/lib/amp-front/dispatch/runner.rb
@@ -23,9 +23,7 @@ def initialize(args, opts={})
end
def run!
- p @args
global_opts, arguments = collect_options(@args)
- p global_opts
load_ampfile!(global_opts[:ampfile]) unless global_opts[:"no-ampfile"]
load_plugins!
View
6 amp-git/spec/spec_helper.rb
@@ -14,9 +14,11 @@
$LOAD_PATH.unshift(File.dirname(__FILE__))
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
+DEPENDENCIES = %w(amp-front amp-core)
+DEPENDENCIES.each do |x|
+ require File.join(File.dirname(__FILE__), '..', '..', x, 'lib', x)
+end
require 'rubygems'
-require 'amp-front'
-require 'amp-core'
require 'amp-git'
require 'spec'
require 'spec/autorun'

0 comments on commit 4293240

Please sign in to comment.