Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Pipeline and Workflow tool
Python
branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
doc
foundation
modules
pipeline
test_suite
CHANGES
INSTALL
README.mkdn

README.mkdn

Wake

Wake is a pipeline and workflow tool based on the pipelines used in the animation industry. It has a huge amount of potential; it just needs a little love and care.

Language

Wake is written in Python as that is fast becoming the main scripting language of the computer animation and whilst it might not seem as funky as Ruby, it’s still pretty damned cool.

Direction

The plan is for this project to grow slowly into a fully functional pipeline with support for the main animation packages like Maya and Houdini. However, smoothly working pipelines are awesomely helpful ways of organising your work and there is no reason why Wake can't be applicable to other areas of life.

Wake is designed in a modular way so additional tools can be built into the framework with little effort.

Install

The project code can be built into Python eggs. The test suite includes a basic script for building the eggs and a script for making an install to /tmp and running through some commands. The scripts:

  • test_suite/setup_clean.tcsh
  • test_suite/test_commands.tcsh

should provide some idea of the basic install steps. Fortunately Python eggs make this pretty easy. The only dependency that isn’t build into the eggs is SQLite which is the database which is used in the default configuration. Wake uses SQLAlchemy and so can handle other databases through that. I run SQLite 3.4.2 which seems to work fine.

To download, build and test wake use the following commands.

git clone git://github.com/michaeljones/wake.git

cd wake/test_suite

./rebuild.tcsh

./test_commands.tcsh

Dependencies

Wake currently uses the following modules:

  • SQLAlchemy
  • Werkzeug
  • Mako

Additionally a database specific layer is required such as sqlite.

Something went wrong with that request. Please try again.