Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Clojure 1.4 is the new default

  • Loading branch information...
commit 066f76d4ee8d36abc38744d9c201009750ca4e93 1 parent 53149dd
@michaelklishin authored
Showing with 10 additions and 4 deletions.
  1. +7 −1 ChangeLog.md
  2. +3 −3 project.clj
View
8 ChangeLog.md
@@ -1,6 +1,12 @@
## Changes between Langohr 1.0.0-beta4 and 1.0.0-beta5
-No changes yet.
+### Clojure 1.4 By Default
+
+Langohr now depends on `org.clojure/clojure` version `1.4.0`. It is still compatible with Clojure 1.3 and if your `project.clj` depends
+on 1.3, it will be used, but 1.4 is the default now.
+
+We encourage all users to upgrade to 1.4, it is a drop-in replacement for the majority of projects out there.
+
## Changes between Langohr 1.0.0-beta3 and 1.0.0-beta4
View
6 project.clj
@@ -2,11 +2,11 @@
:description "An idiomatic Clojure client for RabbitMQ that embraces AMQP 0.9.1 model. Built on top of the RabbitMQ Java client"
:min-lein-version "2.0.0"
:license {:name "Eclipse Public License"}
- :dependencies [[org.clojure/clojure "1.3.0"]
+ :dependencies [[org.clojure/clojure "1.4.0"]
[com.rabbitmq/amqp-client "2.8.6"]
[clojurewerkz/support "0.7.0-beta2"]]
:profiles {:dev { :dependencies [[org.clojure/tools.cli "0.2.1" :exclusions [org.clojure/clojure]]] }
- :1.4 { :dependencies [[org.clojure/clojure "1.4.0"]]}
+ :1.3 { :dependencies [[org.clojure/clojure "1.3.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.0-master-SNAPSHOT"]]}}
:source-paths ["src/clojure"]
:java-source-paths ["src/java"]
@@ -17,6 +17,6 @@
"sonatype-snapshots" {:url "http://oss.sonatype.org/content/repositories/snapshots"
:snapshots true
:releases {:checksum :fail :update :always}}}
- :aliases {"all" ["with-profile" "dev:dev,1.4:dev,1.5"]}
+ :aliases {"all" ["with-profile" "dev:dev,1.3:dev,1.5"]}
:warn-on-reflection true
:jvm-opts ["-Xmx512m"])
Please sign in to comment.
Something went wrong with that request. Please try again.