clojurewerkz.neocons.rest.nodes/find-one returns nil on values having spaces #20

Closed
tutysara opened this Issue Feb 2, 2013 · 3 comments

Comments

Projects
None yet
2 participants
@tutysara

tutysara commented Feb 2, 2013

find-one returns nil on searching indexes with values having spaces.

steps to recreate

(def tst-data {:url "testurl" :name "test name"})

(def tst-node (nn/create tst-data))

(def tst_idx (nn/create-index "tst_idx"))

(nn/add-to-index (:id tst-node) (:name tst_idx) "name" (:name tst-data))

(nn/find-one (:name tst_idx) "name" (:name tst-data))

nil

@michaelklishin

This comment has been minimized.

Show comment
Hide comment
@michaelklishin

michaelklishin Feb 2, 2013

Owner

Ok, the issue is that Neo4J expects spaces to be encoded as %20 and Neocons currently encodes them as +.

Owner

michaelklishin commented Feb 2, 2013

Ok, the issue is that Neo4J expects spaces to be encoded as %20 and Neocons currently encodes them as +.

michaelklishin pushed a commit that referenced this issue Feb 3, 2013

@michaelklishin

This comment has been minimized.

Show comment
Hide comment
@michaelklishin

michaelklishin Feb 6, 2013

Owner

1.1.0-beta3 is out with a fix. Backporting to 1.0.x is tricky because there is a new dependency added and overall
changes are somewhat more extensive than I originally wanted.

Owner

michaelklishin commented Feb 6, 2013

1.1.0-beta3 is out with a fix. Backporting to 1.0.x is tricky because there is a new dependency added and overall
changes are somewhat more extensive than I originally wanted.

@tutysara

This comment has been minimized.

Show comment
Hide comment
@tutysara

tutysara Feb 6, 2013

so many places to change...
thx for the fix.

tutysara commented Feb 6, 2013

so many places to change...
thx for the fix.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment