Skip to content
Permalink
Browse files

Changed the Codeception version to run on Travis for testing against …

…PHP 5.6.
  • Loading branch information...
michaeluno committed Feb 23, 2019
1 parent 184941d commit 747b588aeb294e36c20f36d02a61bf4dd6753112
Showing with 21 additions and 17 deletions.
  1. +21 −17 test/include/downloadCodeception.sh
@@ -1,11 +1,15 @@
#!/usr/bin/env bash
downloadCodeception() {

# The Latest Version
# download "http://codeception.com/codecept.phar" "$1"
# For other versions @see https://codeception.com/builds
# download "http://codeception.com/codecept.phar" "$1"

# v2.5.4 for PHP 5.6
download "https://codeception.com/releases/2.5.4/php54/codecept.phar" "$1"

# v2.5.1 (stable as of 2018/11/01)
download "http://codeception.com/releases/2.5.1/codecept.phar" "$1"
# v2.5.1 (stable as of 2018/11/01) -> does not run on Travis tests against PHP 5.6
# download "http://codeception.com/releases/2.5.1/codecept.phar" "$1"

# v2.5.0
# download "https://codeception.com/releases/2.5.0/codecept.phar" "$1"
@@ -24,36 +28,36 @@ downloadCodeception() {

# v2.1.6
# download "http://codeception.com/releases/2.1.6/codecept.phar" "$1"

# v2.1 - $I->click() does not work...
# v2.0.12 - Working but unable to set cURL timeouts in PHPBrowser.

# v2.0.12 - Working but unable to set cURL timeouts in PHPBrowser.
# download "http://codeception.com/releases/2.0.12/codecept.phar" "$1"

# v2.0.11 - Unable to set cURL timeouts in PHPBrowser.
# download "http://codeception.com/releases/2.0.11/codecept.phar" "$1"

# v2.0.7 - needs 30000 cURL timeout @see https://github.com/Codeception/Codeception/issues/1984#issuecomment-113561925
# but this version does not load accurate urls in PHPBrowser.
# download "http://codeception.com/releases/2.0.7/codecept.phar" "$1"

# v1.8.7 - causes an error " Path for logs is not writable. Please, set appropriate access mode for log"
# download "http://codeception.com/releases/1.8.7/codecept.phar" "$1"
# download "http://codeception.com/releases/1.8.7/codecept.phar" "$1"

if [[ ! $(find "$1" -type f -size +0c 2>/dev/null) ]]; then
echo Could not download Codeception.
exit 1
fi
# Output the version in case an error occurs.
php "$1" --version
# c3
php "$1" --version

# c3
# @see https://github.com/Codeception/c3
# download "https://raw.github.com/Codeception/c3/2.0/c3.php" "$C3"
# if [[ ! $(find "$C3" -type f -size +0c 2>/dev/null) ]]; then
# echo Could not download c3.php.
# exit 1
# fi


}

0 comments on commit 747b588

Please sign in to comment.
You can’t perform that action at this time.