[enhancement] Add missing bower.json. #142

Closed
timgluz opened this Issue Jan 7, 2014 · 2 comments

Comments

Projects
None yet
2 participants

timgluz commented Jan 7, 2014

Hey, maintainer(s) of michelf/php-markdown!

We at VersionEye are working hard to keep up the quality of the bower's registry.

We just finished our initial analysis of the quality of the Bower.io registry:

7530 - registered packages, 224 of them doesnt exists anymore;

We analysed 7306 existing packages and 1070 of them don't have bower.json on the master branch ( that's where a Bower client pulls a data ).

Sadly, your library michelf/php-markdown is one of them.

Can you spare 15 minutes to help us to make Bower better?

Just add a new file bower.json and change attributes.

{
  "name": "michelf/php-markdown",
  "version": "1.0.0",
  "main": "path/to/main.css",
  "description": "please add it",
  "license": "Eclipse",
  "ignore": [
    ".jshintrc",
    "**/*.txt"
  ],
  "dependencies": {
    "<dependency_name>": "<semantic_version>",
    "<dependency_name>": "<Local_folder>",
    "<dependency_name>": "<package>"
  },
  "devDependencies": {
    "<test-framework-name>": "<version>"
  }
}

Read more about bower.json on the official spefication and nodejs semver library has great examples of proper versioning.

NB! Please validate your bower.json with jsonlint before commiting your updates.

Thank you!

Timo,
twitter: @versioneye
email: timo@versioneye.com
VersionEye - no more legacy software!

Owner

michelf commented Jan 15, 2014

This makes no sense to me. Why would someone want to use a package manager that requires node.js to install a PHP library?

timgluz commented Jan 15, 2014

I have no idea - but fact is that your library is registered on bower list and someone has registered it there . Btw here is instructions how to remove it on list.

@timgluz timgluz closed this Jan 15, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment