highcharts js version conflict #74

xiaods opened this Issue Aug 31, 2012 · 1 comment

1 participant


evaluate from issue#73, introduce new bug for highcharts version.

Highcharts JS v2.3.1 (2012-08-29) from highcharts site.
lazy_high_charts, use rails g lazy_high_charts:install will install from github. highcharts stock branch.
the version always https://raw.github.com/highslide-software/highcharts.com/stock/js/highcharts.src.js

in lazy_high_charts gem version 1.2.0 below url is outage, need update asap
def install_highcharts(opts = nil)

6 say_status("installing", "Highcharts javascript (github STOCK branch)", :green)
7 if ::Rails::VERSION::MAJOR == 3 && ::Rails::VERSION::MINOR >= 1

8 get 'http://highcharts.com/js/highstock.js', 'vendor/assets/javascripts/highcharts.js'
9 else

10 get "https://raw.github.com/highslide-software/highcharts.com/stock/js/highcharts.src.js","public/javascripts/highcharts.js"
11 end

12 rescue OpenURI::HTTPError

13 say_status("warning", "could not find Highcharts javascript file", :yellow)
14 end

@xiaods xiaods was assigned Aug 31, 2012

fixed, need merge to gem version

@xiaods xiaods closed this Aug 31, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment