New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wheels have random white border lines in 2.5.1 #530

Closed
jhdgghost opened this Issue Jan 5, 2019 · 5 comments

Comments

Projects
None yet
2 participants
@jhdgghost
Copy link

jhdgghost commented Jan 5, 2019

20190105_170747

AM 2.5.1 show sometimes strange white border lines in wheels.

That is not happening in previous versions. The effect is random happen with some wheels. If you scroll the wheel several time the border effect is more evident in more games.

Happens also in different layouts. And also i not think is the png because in previous versions i did not notice the lines.

Check the photo attached.

Kind Regards

@oomek

This comment has been minimized.

Copy link
Collaborator

oomek commented Jan 6, 2019

Try this Photoshop plugin https://github.com/oomek/SuperPNG/releases resave one of the pngs that has this lines with "clean transparent" ticked and report the results. If it helps I'll know if this is what I think it is.
Also would you provide a debug log and tell what hardware and system you are running AM on please

@jhdgghost

This comment has been minimized.

Copy link

jhdgghost commented Jan 6, 2019

Hi oomek,

I did as you say i resave the file Fantasy Star Soldier (USA).png with SUPERpng plugin for photoshop but yet with the new file the borders are there (photo).

I attach also the log for my session in putty opening attract-mode with attract --loglevel debug. If there is a better way to get detailed debug log please tell me and i will do it again

Sorry my stupid mistake not telling the software or hardware. I am running last version of attract-mode in retropie 4.4 in a raspberry 3b+.

Hope it helps.

20190106_131610

putty.log

@oomek

This comment has been minimized.

Copy link
Collaborator

oomek commented Jan 7, 2019

Thank you for your report. I was able to reproduce the problem. We will try to find the source of those blending errors.

@oomek

This comment has been minimized.

Copy link
Collaborator

oomek commented Jan 8, 2019

Could you check the following branch and test if the issue with white lines on pngs border has ben resolved please? You can just simply replace the repositiry url in the update script

-b dev-pi https://github.com/oomek/attract

@jhdgghost

This comment has been minimized.

Copy link

jhdgghost commented Jan 8, 2019

Hi,

Just checked and the issue is perfectly fixed.

Thanks

@jhdgghost jhdgghost closed this Jan 19, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment