Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Element not found" after install KB4571756 #5880

Closed
Mystic8b opened this issue Sep 8, 2020 · 135 comments
Closed

"Element not found" after install KB4571756 #5880

Mystic8b opened this issue Sep 8, 2020 · 135 comments

Comments

@Mystic8b
Copy link

@Mystic8b Mystic8b commented Sep 8, 2020

Environment

Windows build number: Microsoft Windows NT 10.0.19042.0
Your Distribution version: Ubuntu 20.04 (WSL 2)

Steps to reproduce

Install KB4571756
Reboot PC
Launch Windows Terminal with WSL

WSL logs: https://aka.ms/AA9kmq5

Expected behavior

WSL just works

Actual behavior

Element not found.
Process exited with code 4294967295
image

@Mystic8b Mystic8b changed the title "Element not found" after "Element not found" after install KB4571756 Sep 8, 2020
@Mystic8b
Copy link
Author

@Mystic8b Mystic8b commented Sep 8, 2020

Now i got a WSL update via update center but it didn't help.

@dvv47
Copy link

@dvv47 dvv47 commented Sep 8, 2020

image
Same problem

@EgoistDeveloper
Copy link

@EgoistDeveloper EgoistDeveloper commented Sep 9, 2020

After the KB4571756 windows update I also got this error. I deleted the docker folders in AppData, then uninstalled and reinstalled docker but it didn't fix. It finally worked when I uninstalled the latest windows quality updates. (docker is associated with wsl in this case.)

Caution: If you're not sure what you're doing, check out the tutorials on the web!

  • Sign out and hold shift while clicking restart button on lock screen
  • After restart, select Troubleshoot>Advanced options>Uninstall Updates>Uninstall latest quality update
  • Then enter related Microsoft account credentials and when all done > select Continue option.

This is not a real solution but you can keep working at least until Microsoft fixes the problem.

@therealkenc
Copy link
Collaborator

@therealkenc therealkenc commented Sep 9, 2020

Ref #5002 #5631. Appreciate the OP logs, thanks.

@cl1933404370
Copy link

@cl1933404370 cl1933404370 commented Sep 9, 2020

I have the problem too. And i won't to remove KB4571756.
I had to transfer this Distribution from wsl2 to wsl1.
hoping fixing this bug quickly.
log.zip

@dafoxuk
Copy link

@dafoxuk dafoxuk commented Sep 9, 2020

Removing the KB4571756 Windows update has fixed the problem for me as well

@francescarpi
Copy link

@francescarpi francescarpi commented Sep 9, 2020

Me too. I have had to remove the KB4571756 update. I'll wait a few days for try to update again.

@AnMaillard
Copy link

@AnMaillard AnMaillard commented Sep 9, 2020

I can confirm that the workaround of @EgoistDeveloper (uninstalling the KB4571756 update) solved the problem for me too.

@Smallthing
Copy link

@Smallthing Smallthing commented Sep 9, 2020

when I turn off my computer ,docker report error and wsl s exited with code
....
I'm really stupid.then I uninstalled my wsl2 ..when I install them back .

click the ubuntu icon.and it said:

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x800706be
Error: 0x800706be ?????????

Press any key to continue...

I don't know where to get logs.
hope this bug solve faster...

@francescarpi
Copy link

@francescarpi francescarpi commented Sep 9, 2020

when I turn off my computer ,docker report error and wsl s exited with code
....
I'm really stupid.then I uninstalled my wsl2 ..when I install them back .

click the ubuntu icon.and it said:

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x800706be
Error: 0x800706be ?????????

Press any key to continue...

I don't know where to get logs.
hope this bug solve faster...

Please, check this issue #5768

@malkia
Copy link

@malkia malkia commented Sep 9, 2020

Hmm.. I'm with "2004" e.g. "10.0.19041.508" and both wsl2 (kali-linux) and docker (through wsl2) work fine. Maybe my update got updated (Just did an update)

image

@therealkenc
Copy link
Collaborator

@therealkenc therealkenc commented Sep 9, 2020

I don't know where to get logs.

WSL logs

@chungweileong94
Copy link

@chungweileong94 chungweileong94 commented Sep 9, 2020

Facing the same thing, uninstall the update doesn't help.
I ended up reinstall the Windows.

@sozercan
Copy link
Member

@sozercan sozercan commented Sep 9, 2020

With KB4571756 update (19042.508), was getting this error:

The remote procedure call failed. 
[process exited with code 4294967295]

After uninstalling KB4571756 and reverting to 19042.487, WSL2 starts again.

@francescarpi
Copy link

@francescarpi francescarpi commented Sep 9, 2020

Hi again,

My windows version:

Edición Windows 10 Pro
Versión 20H2
Instalado el ‎28/‎05/‎2020
Versión del sistema operativo 19042.508
Experiencia Windows Feature Experience Pack 120.2212.31.0

My last update:
KB4571756

This is my error:

image

I thing it's the error:

image

Nombre de la aplicación con errores: vmwp.exe, versión: 10.0.19041.488, marca de tiempo: 0xfc760123
Nombre del módulo con errores: KERNELBASE.dll, versión: 10.0.19041.488, marca de tiempo: 0x5b4a3325
Código de excepción: 0xc0000409
Desplazamiento de errores: 0x000000000010b3cc
Identificador del proceso con errores: 0x210c
Hora de inicio de la aplicación con errores: 0x01d686cca3eca54e
Ruta de acceso de la aplicación con errores: C:\Windows\System32\vmwp.exe
Ruta de acceso del módulo con errores: C:\WINDOWS\System32\KERNELBASE.dll
Identificador del informe: d8a5e558-04fe-44a3-8927-d53e7eb08af2
Nombre completo del paquete con errores: 
Identificador de aplicación relativa del paquete con errores: 

I attach the log output.

error.zip

I'm not sure if it is the right error, but something its better than nothing xD

Thank you!

@chadbrewbaker
Copy link

@chadbrewbaker chadbrewbaker commented Sep 9, 2020

Same issue as @francescarpi "The remote procedure call failed." 20H2 build 19042.508
From: https://techdows.com/2020/09/windows-10-kb4571756-is-breaking-windows-subsystem-for-linux-2-wsl-2.html

Open Control Panel
Programs > Programs and Features > Installed Updates
Select “Update for Microsoft Windows (KB4571756)
Click Uninstall KB4571756

@Brian-Perkins
Copy link
Collaborator

@Brian-Perkins Brian-Perkins commented Sep 9, 2020

The "remote procedure call failed" issue may be #5768 (e.g. try wsl --update). If anyone is seeing the "element not found" issue we are still looking for more WSL logs

@dvv47
Copy link

@dvv47 dvv47 commented Sep 9, 2020

@Brian-Perkins --update argument unknown
it shows help

logs captured - https://aka.ms/AA9l56g

@coxchris859
Copy link

@coxchris859 coxchris859 commented Sep 9, 2020

I have no error when booting up to wsl or running with the windows terminal

Maybe this only applies to Windows 10 Pro with native hyper-v support. Window 10 home doesn't support Hyper-V natively
WSL

@chadbrewbaker
Copy link

@chadbrewbaker chadbrewbaker commented Sep 10, 2020

@coxchris859 you might be on to something. I’m on win10 pro. Downgrading as per above worked for now.

@Brian-Perkins
Copy link
Collaborator

@Brian-Perkins Brian-Perkins commented Sep 10, 2020

If anyone is hitting the "remote procedure call failed" error related to KB4571756 #5890 would be a good landing spot for that. We will look at logs posted there as well.

@cknoettg
Copy link

@cknoettg cknoettg commented Sep 10, 2020

I second the opinion that the problem does not exist if Hyper-V is not installed...I am having no problems after applying KB4571756 on Win 10 2004. I did a little stress-testing. I made absolutely sure that vmwp.exe was running. My vmwp.exe updated at the same time as I installed KB4571756. I ran VMWare, and no issues either.
vmwp

@alexanderv21
Copy link

@alexanderv21 alexanderv21 commented Sep 10, 2020

Having the same issue and fixed by uninstalling the latest update (KB4571756)

@Smallthing
Copy link

@Smallthing Smallthing commented Sep 10, 2020

when I turn off my computer ,docker report error and wsl s exited with code
....
I'm really stupid.then I uninstalled my wsl2 ..when I install them back .
click the ubuntu icon.and it said:

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x800706be
Error: 0x800706be ?????????

Press any key to continue...

I don't know where to get logs.
hope this bug solve faster...

Please, check this issue #5768

ok
thank you ,they said fix is inbound.
so I have to wait right?

@coxchris859
Copy link

@coxchris859 coxchris859 commented Sep 10, 2020

@coxchris859 you might be on to something. I’m on win10 pro. Downgrading as per the above worked for now.

Ok Hyper-Visor is a native window core component to Windows 10 Pro and Enterprise and Education. Maybe disableling will temporarily fix it

https://support.microsoft.com/en-us/help/3204980/virtualization-applications-do-not-work-together-with-hyper-v-device-g

@Smallthing
Copy link

@Smallthing Smallthing commented Sep 10, 2020

@coxchris859 you might be on to something. I’m on win10 pro. Downgrading as per the above worked for now.

Ok Hyper-Visor is a native window core component to Windows 10 Pro and Enterprise and Education. Maybe disableling will temporarily fix it

https://support.microsoft.com/en-us/help/3204980/virtualization-applications-do-not-work-together-with-hyper-v-device-g

I don't know the best practice for wsl2 on win10 pro.
for example: there are hypervisor platform, hyper-v hypervisor ,which one need to open for just wsl2?

@coxchris859
Copy link

@coxchris859 coxchris859 commented Sep 10, 2020

On Windows Home, I don't have it installed at all period Windows Hypervisor Platform.

I went to Step 1 to download the optional feature
https://docs.microsoft.com/en-us/windows/wsl/install-win10
Update to WSL 2:

I had all the pre-requirement for WSL 2 I didn't have WSL1 they updated the WSL in Windows 10 2004

See the article for reference: https://devblogs.microsoft.com/commandline/wsl2-will-be-generally-available-in-windows-10-version-2004/
Running Windows 10, updated to version 1903 or higher, Build 18362 or higher for x64 systems.

Then I installed the updated WSL2 Linux Kernal https://docs.microsoft.com/en-us/windows/wsl/wsl2-kernel

@dy55
Copy link

@dy55 dy55 commented Sep 10, 2020

I have the same problem. The update was installed on my PC this afternoon, then my WSL 2 cannot start properly. 🤯

image

That must be caused by the update KB4571756.

Hope Microsoft to solve the problem quickly.

@mbatesco
Copy link

@mbatesco mbatesco commented Sep 10, 2020

I removed KB4571756 yesterday and the issue went away. Reboot the machine this morning and MS reapplied the update and it broke WSL and Docker. -- Removed and things are fine again.

@sundhaug92
Copy link

@sundhaug92 sundhaug92 commented Sep 22, 2020

As a bit of telemetry: I went straight from 20h1 to 20h2 RP and haven't had any such issue. Using Windows Defender

@dvv47
Copy link

@dvv47 dvv47 commented Sep 22, 2020

https://blogs.windows.com/windows-insider/2020/09/22/announcing-windows-10-insider-preview-build-19042-541-20h2/

We have fixed the issue where WSL fails to start with an “Element not found” error.
@markexperience
Copy link

@markexperience markexperience commented Sep 22, 2020

@coxchris859
Copy link

@coxchris859 coxchris859 commented Sep 22, 2020

https://blogs.windows.com/windows-insider/2020/09/22/announcing-windows-10-insider-preview-build-19042-541-20h2/

We have fixed the issue where WSL fails to start with an “Element not found” error.

Come on Microsoft development. I thought about that when I was reading your reply........ Markexpeirnece

So... in order to get the official fix we have to sign up for insider/preview and all its associated telemetry gathering shenanigans? When will the fix make it to the regular update channel? WSL2 support was the one thing that pulled me back to Windows 10 from PopOs. I'm getting closer to reversing that move daily.

Sometimes they make it available before it hits the Windows Update Catalog and or Windows Update. You have to download the iso for 20H2.

@markexperience
Copy link

@markexperience markexperience commented Sep 22, 2020

@teodoryantcheff
Copy link

@teodoryantcheff teodoryantcheff commented Sep 22, 2020

Confirmed KB4577063 did fix my 'Element not found' issue!

@francescarpi
Copy link

@francescarpi francescarpi commented Sep 22, 2020

Is it necessary to remove VmSynthNic.dll before update?

Thx

@alex73630
Copy link

@alex73630 alex73630 commented Sep 24, 2020

Is there a known fix for build 20221 (Dev Channel)?
I can't uninstall KB4571756 and KB4577063 isn't available anywhere.

@teodoryantcheff
Copy link

@teodoryantcheff teodoryantcheff commented Sep 24, 2020

Is there a known fix for build 20221 (Dev Channel)?
I can't uninstall KB4571756 and KB4577063 isn't available anywhere.

@alex73630 https://www.deskmodder.de/blog/2020/09/22/kb4577063-manueller-download-windows-10-windows-10-2004-und-windows-10-20h2/

There are direct download links near the bottom of this page.

@alex73630
Copy link

@alex73630 alex73630 commented Sep 24, 2020

Thanks @teodoryantcheff but I can't even manually install the KB on the build 20221, see output (in French)

PS C:\WINDOWS\system32> DISM.exe /Online /Add-Package /PackagePath:"C:\Users\Alexandre\Downloads\windows10.0-kb4577063-x64_51ae9d1580dd139fca97d0df5956fe6a1f009f2a.cab" /NoRestart

Outil Gestion et maintenance des images de déploiement
Version : 10.0.20221.1000

Version de l’image : 10.0.20221.1000

Traitement de 1 sur 1 - Ajout du package Package_for_RollupFix~31bf3856ad364e35~amd64~~19041.541.1.11
[==========================100.0%==========================]

Erreur : 0x800f081e

Le package spécifié n’est pas applicable à cette image.

Le fichier journal DISM se trouve à l’emplacement C:\WINDOWS\Logs\DISM\dism.log

Here is the DISM log : dism.log
TLDR: It can't apply the KB on the build 20221

@teodoryantcheff
Copy link

@teodoryantcheff teodoryantcheff commented Sep 24, 2020

No idea, @alex73630. I just googled it for your convenience. OTOH also not sure you need to be on the dev builds either.

@ezar
Copy link

@ezar ezar commented Sep 25, 2020

C:\Users\Alexandre\Downloads\windows10.0-kb4577063-x64_51ae9d1580dd139fca97d0df5956fe6a1f009f2a.cab" /NoRestart

Same here!

@coxchris859
Copy link

@coxchris859 coxchris859 commented Sep 25, 2020

I think you cannot just install that KB with the standalone. The Hotfix is a prerequisite of Windows 2040 or the next installment of Windows. If Microsoft issue a standalone fix then we will just have it. Although I agree with you all that they broke it they cant just release it this close to the actual release of Windows 20H2.

The only solution is the Windows Insider Program and download that iso if you are willing to give up your privacy for that program. Once they update the Windows ISO from the media creation tool then you can just download the iso without having to wait for the rollouts of being a feature update.

@ArthurJam
Copy link

@ArthurJam ArthurJam commented Sep 29, 2020

Hello,

Im always stuck on this bug, i didnt found a solution for this.
I need to retrieve files on my linux filesystem.

Do you know if i can retrieve some files without starting wsl ?

@mnickkk
Copy link

@mnickkk mnickkk commented Sep 29, 2020

While the issue itself is perfectly understandable, I cannot express how deeply dissatisfied I am with the way Microsoft shoves updates down my throat, literally.

When this issue has occurred for the first time I simply reverted the last update and was fine (for a day or two). Two days later this build was back on my PC (no worries, I can just revert and grab a coffee before I start my day). Me and my Windows were fighting back and forth (update & revert) for some time, but that's the price you got to pay for running a dev channel build, we lived a happy life... UNTIL ANOTHER WILD UPDATE APPEARED (do you see where I'm going?). Now I can revert latest update, but that won't bring back my working environment - the last two updates are WSL broken and I cannot revert more.

Some may say that I should have paused the updates for 7 days, but:

  • I didn't know such feature existed, in fact I assumed that if I explicitly got rid of a build, I'll need to agree for the next update (unless that's a security patch), like: "Hey, we've fixed this and this and that, wanna try?" - after all Dev channel is for "highly technical users",let us make the call;
  • this issue is over 1 month old, imagine disabling that for 7 days and on the 8th day the doom comes

...and for Windows 20H2 I need to do a fresh install.

There's a reason people opted for the dev channel - WSL2 with Docker support enabled me to ditch my MBP completely.
Please let us stay in the loop by using Dev channel, but without sacrificing so much.

@Qynklee
Copy link

@Qynklee Qynklee commented Oct 1, 2020

@andressltz
Copy link

@andressltz andressltz commented Oct 2, 2020

To fix, install this update KB4577063 (Windows 10 Build 19041.546) launched 10/01/2020, this issue has fixed in this update.

@markexperience
Copy link

@markexperience markexperience commented Oct 2, 2020

@baracunatana
Copy link

@baracunatana baracunatana commented Oct 2, 2020

Might be. But, at the same time, what's de point of keeping the issue open if all that is left is for the KB4577063 patch to run its curse?

@coxchris859
Copy link

@coxchris859 coxchris859 commented Oct 2, 2020

They have release a standalone KB patch that isn't apart of the 20H2 feature update

@markexperience
Copy link

@markexperience markexperience commented Oct 2, 2020

@bazilious
Copy link

@bazilious bazilious commented Oct 3, 2020

LOL guys, the bug was on the insider builds anyway. If you are not an insider you don't have it, plain and simple.

@malkia
Copy link

@malkia malkia commented Oct 6, 2020

To fix, install this update KB4577063 (Windows 10 Build 19041.546) launched 10/01/2020, this issue has fixed in this update.

I've found certain apps not to be working with this one (and had to revert it). One of them is AppVerif - the command-line still works, but the UI needs "EdgeGDI.dll" which is not present (seems to be loaded by newer gdi32.dll, but not so sure). Searching for "EdgeGDI" reveals other apps that maybe missing it. It might not affect you, or what you do daily, but it affected me, and had to revert.

@dopewind
Copy link

@dopewind dopewind commented Oct 16, 2020

@Mystic8b Totally unrelated question, but can you share your Windows Terminal profiles.json 😅

@Mystic8b
Copy link
Author

@Mystic8b Mystic8b commented Oct 16, 2020

@Mystic8b Totally unrelated question, but can you share your Windows Terminal profiles.json 😅

Sure 😉Take it
Oh yeah, and icons

@dopewind
Copy link

@dopewind dopewind commented Oct 16, 2020

@Mystic8b Totally unrelated question, but can you share your Windows Terminal profiles.json 😅

Sure 😉Take it
Oh yeah, and icons

@Mystic8b Thanks dude, appreciate it

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
You can’t perform that action at this time.