render blank pages after upgrading middleman to 3.3.2 #207

Closed
kidwm opened this Issue Apr 11, 2014 · 10 comments

Projects

None yet

4 participants

@kidwm
kidwm commented Apr 11, 2014

the repo:
https://github.com/4point/osdc.tw
all blog pages are under /news/ but now get blank content.

@Arcovion
Member

This should be = wrap_layout instead of - wrap_layout:
https://github.com/4point/osdc.tw/blob/master/source/layouts/article.haml

May also require other changes, see middleman/middleman#1249

@kidwm
kidwm commented Apr 11, 2014

@Arcovion Thanks.
@tdreyno maybe we should give some helper examples in CHANGELOG ?

@kidwm kidwm closed this Apr 11, 2014
@Arcovion
Member

It's in the middleman changelog, just not middleman-blog

@kidwm
kidwm commented Apr 11, 2014

@Arcovion I know that, but I didn't get the idea at the first glance.

@kidwm
kidwm commented Apr 11, 2014

It says 'tag helpers' in Padrino's upgrading guide, so I overlook this case.

@tdreyno
Member
tdreyno commented Apr 11, 2014

@kidwm Are there docs/examples using the old syntax still?

@kidwm
kidwm commented Apr 14, 2014

@tdreyno It seems still be.
http://middlemanapp.com/basics/templates/

<% wrap_layout :layout do %>
  <article>
    <%= yield %>
  </article>
<% end %>
@lolmaus
Contributor
lolmaus commented Apr 14, 2014

I think we should leave a note of the old syntax in each example. There are still people supporting projects with Middleman locked at older versions.

@tdreyno
Member
tdreyno commented Apr 14, 2014

@kidwm This issue only applies to Haml/Slim, not erb.

@kidwm
kidwm commented Apr 15, 2014

@tdreyno Oops, I forgot that. That really makes confusing.

@Arcovion Arcovion referenced this issue in middleman/middleman May 10, 2014
Closed

middleman-core 3.3.2: wrap_layout broken #1275

@ghedamat ghedamat added a commit to ghedamat/middleman-guides that referenced this issue Dec 4, 2014
@ghedamat ghedamat update syntax for wrap_layout
see middleman/middleman-blog#207 (comment)

got bitten by this today, I understand that the old version is ok before 3.3.2, but I think this should do no harm

let me know if this is ok :)

thanks!
83db300
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment