New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Install issues no such file to load --middleman-more (loadError) #684

Closed
benfrain opened this Issue Dec 12, 2012 · 7 comments

Comments

Projects
None yet
2 participants
@benfrain

benfrain commented Dec 12, 2012

I've installed Middleman on my 'home' machine with no issues. For some reason, I'm not having any luck on my 'work' system.

After installing middleman (sudo gem install middleman) I run:

middleman --help and I get this:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem middleman-core (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
    from /usr/bin/middleman:18

I've then tried running sudo gem install middleman-core which completes but when I try middleman --help I get the same error message.

I've spent (literally and ashamedly) over a day trying to figure this to no avail. I'm a front-end chap so a lot of this Ruby stuff goes way over my head.

Any pointers would be greatly appreciated.

Note:
I've managed to get some success by using RVM instead of the default Ruby but then things like CodeKit don't compile. I don't want to go down the RVM route if possible.

@tdreyno

This comment has been minimized.

Show comment
Hide comment
@tdreyno

tdreyno Dec 12, 2012

Member

What is the results of gem list

Member

tdreyno commented Dec 12, 2012

What is the results of gem list

@tdreyno

This comment has been minimized.

Show comment
Hide comment
@tdreyno

tdreyno Dec 12, 2012

Member

Also, gem --version

Member

tdreyno commented Dec 12, 2012

Also, gem --version

@benfrain

This comment has been minimized.

Show comment
Hide comment
@benfrain

benfrain Dec 12, 2012

Drat, time difference means I won't be able to check this for another 12 hours. Will do both these and post the results. Thanks for the help Mr Reynolds.

benfrain commented Dec 12, 2012

Drat, time difference means I won't be able to check this for another 12 hours. Will do both these and post the results. Thanks for the help Mr Reynolds.

@benfrain

This comment has been minimized.

Show comment
Hide comment
@benfrain

benfrain Dec 13, 2012

OK, here are the results of gem list:

activesupport (3.2.9)
bundler (1.2.3)
chunky_png (1.2.6)
coffee-script (2.2.0)
coffee-script-source (1.4.0, 1.3.3)
color-hacker (1.0.0)
compass (0.12.2)
compass-magick (0.1.6)
execjs (1.4.0)
ffi (1.2.0)
fssm (0.2.9)
haml (3.1.7)
hike (1.2.1)
http_router (0.10.2)
i18n (0.6.1)
listen (0.5.3)
maruku (0.6.1)
middleman (3.0.6)
middleman-core (3.0.6)
middleman-more (3.0.6)
middleman-sprockets (3.0.4)
multi_json (1.5.0)
oily_png (1.0.2)
padrino-core (0.10.7)
padrino-helpers (0.10.7)
rack (1.4.1)
rack-protection (1.3.1)
rack-test (0.6.2)
rb-fsevent (0.9.2)
rb-inotify (0.8.8)
rvm (1.11.3.5)
sass (3.2.3, 3.2.2)
sinatra (1.3.3)
sprockets (2.4.5)
sprockets-sass (0.8.0)
susy (1.0.5, 1.0.4)
syntax (1.0.0)
thor (0.15.4)
tilt (1.3.3)
uglifier (1.2.7)
url_mount (0.2.1)
zen-grids (1.2)

benfrain commented Dec 13, 2012

OK, here are the results of gem list:

activesupport (3.2.9)
bundler (1.2.3)
chunky_png (1.2.6)
coffee-script (2.2.0)
coffee-script-source (1.4.0, 1.3.3)
color-hacker (1.0.0)
compass (0.12.2)
compass-magick (0.1.6)
execjs (1.4.0)
ffi (1.2.0)
fssm (0.2.9)
haml (3.1.7)
hike (1.2.1)
http_router (0.10.2)
i18n (0.6.1)
listen (0.5.3)
maruku (0.6.1)
middleman (3.0.6)
middleman-core (3.0.6)
middleman-more (3.0.6)
middleman-sprockets (3.0.4)
multi_json (1.5.0)
oily_png (1.0.2)
padrino-core (0.10.7)
padrino-helpers (0.10.7)
rack (1.4.1)
rack-protection (1.3.1)
rack-test (0.6.2)
rb-fsevent (0.9.2)
rb-inotify (0.8.8)
rvm (1.11.3.5)
sass (3.2.3, 3.2.2)
sinatra (1.3.3)
sprockets (2.4.5)
sprockets-sass (0.8.0)
susy (1.0.5, 1.0.4)
syntax (1.0.0)
thor (0.15.4)
tilt (1.3.3)
uglifier (1.2.7)
url_mount (0.2.1)
zen-grids (1.2)

@benfrain

This comment has been minimized.

Show comment
Hide comment
@benfrain

benfrain Dec 13, 2012

Here is the result of gem --version

1.3.6

Does that shed any light?

benfrain commented Dec 13, 2012

Here is the result of gem --version

1.3.6

Does that shed any light?

@tdreyno

This comment has been minimized.

Show comment
Hide comment
@tdreyno

tdreyno Dec 13, 2012

Member

See if sudo gem update --system helps you out. That will update Rubygems to the latest version (which is what you'd get with a new copy of rvm).

Member

tdreyno commented Dec 13, 2012

See if sudo gem update --system helps you out. That will update Rubygems to the latest version (which is what you'd get with a new copy of rvm).

@benfrain

This comment has been minimized.

Show comment
Hide comment
@benfrain

benfrain Dec 14, 2012

OK, ran that and got this response

Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.8.24
Updating RubyGems to 1.8.24
Installing RubyGems 1.8.24
RubyGems 1.8.24 installed

== 1.8.24 / 2012-04-27

* 1 bug fix:

  * Install the .pem files properly. Fixes #320
  * Remove OpenSSL dependency from the http code path


------------------------------------------------------------------------------

RubyGems installed the following executables:
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem

All seems to be working perfectly now. Thanks very much Mr Reynolds!

benfrain commented Dec 14, 2012

OK, ran that and got this response

Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.8.24
Updating RubyGems to 1.8.24
Installing RubyGems 1.8.24
RubyGems 1.8.24 installed

== 1.8.24 / 2012-04-27

* 1 bug fix:

  * Install the .pem files properly. Fixes #320
  * Remove OpenSSL dependency from the http code path


------------------------------------------------------------------------------

RubyGems installed the following executables:
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem

All seems to be working perfectly now. Thanks very much Mr Reynolds!

@benfrain benfrain closed this Dec 14, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment