Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 52 lines (43 sloc) 1.753 kB
4a6ec6a @mightybyte Work in progress
authored
1 name: snaplet-postgresql-simple
2 version: 0.1
3 synopsis: postgresql-simple snaplet for the Snap Framework
4 description: This snaplet contains support for using the Postgresql
5 database with a Snap Framework application via the
6 postgresql-simple package. It also includes an
7 authentication backend.
8 license: BSD3
9 license-file: LICENSE
10 author: Doug Beardsley
11 maintainer: mightybyte@gmail.com
12 build-type: Simple
13 cabal-version: >= 1.6
14 homepage: https://github.com/mightybyte/snaplet-postgresql-simple
15 category: Web
16
17 extra-source-files: LICENSE
18
6fbf493 @mightybyte Ship with default config files
authored
19 data-files:
6c768d7 @mightybyte Update cabal file for new config file names.
authored
20 resources/db/devel.cfg
21 resources/auth/devel.cfg
6fbf493 @mightybyte Ship with default config files
authored
22
4a6ec6a @mightybyte Work in progress
authored
23 source-repository head
24 type: git
25 location: https://github.com/mightybyte/snaplet-postgresql-simple.git
26
27 Library
28 hs-source-dirs: src
29
30 exposed-modules:
31 Snap.Snaplet.PostgresqlSimple
262c120 @mightybyte Started working on auth backend.
authored
32 Snap.Snaplet.Auth.Backends.PostgresqlSimple
6fbf493 @mightybyte Ship with default config files
authored
33 Paths_snaplet_postgresql_simple
4a6ec6a @mightybyte Work in progress
authored
34
35 build-depends:
36 base >= 4 && < 5,
04196de @mightybyte Finish off the main API.
authored
37 bytestring >= 0.9.1 && < 0.10,
262c120 @mightybyte Started working on auth backend.
authored
38 clientsession >= 0.7.2 && < 0.8,
39 configurator >= 0.2 && < 0.3,
4a6ec6a @mightybyte Work in progress
authored
40 MonadCatchIO-transformers >= 0.2.1 && < 0.3,
04196de @mightybyte Finish off the main API.
authored
41 mtl > 2.0 && < 2.1,
4a6ec6a @mightybyte Work in progress
authored
42 postgresql-simple >= 0.0 && < 0.1,
43 resource-pool-catchio >= 0.2 && < 0.3,
5a2cbc1 @mightybyte Upgraded to 0.9 and the new default config filenames.
authored
44 snap >= 0.9 && < 0.10,
4a6ec6a @mightybyte Work in progress
authored
45 text >= 0.11 && < 0.12,
262c120 @mightybyte Started working on auth backend.
authored
46 transformers >= 0.2 && < 0.3,
47 unordered-containers >= 0.1.4 && < 0.2
48
4a6ec6a @mightybyte Work in progress
authored
49
50 ghc-options: -Wall -fwarn-tabs -funbox-strict-fields
51 -fno-warn-orphans -fno-warn-unused-do-bind
Something went wrong with that request. Please try again.