Skip to content
Browse files

Fix fetcher with sources that don't support prerelease gems

  • Loading branch information...
1 parent 500adb9 commit f71521e5d60478e9aba9f534bc6cda7ba21557f0 @jeremy jeremy committed Jan 2, 2010
Showing with 1 addition and 0 deletions.
  1. +1 −0 lib/bundler/source.rb
View
1 lib/bundler/source.rb
@@ -92,6 +92,7 @@ def fetch_prerelease_specs
Marshal.load(Gem::RemoteFetcher.fetcher.fetch_path("#{uri}/prerelease_specs.4.8.gz"))
rescue Gem::RemoteFetcher::FetchError
Bundler.logger.warn "Source '#{uri}' does not support prerelease gems"
+ []
end
end

0 comments on commit f71521e

Please sign in to comment.
Something went wrong with that request. Please try again.