Relax mime-types requirement to allow v2. #661

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

pwnall commented Feb 3, 2014

This PR fixes #641.

I ran the specs on MRI 2.0.0 on Linux (Fedora 20 x86_64, if it matters) and the spec result is the same for mime-types >~ 1.16 and mime-types >= 1.16 (which resolves to 2.1 on my machine).

The main advantage of this approach, over straight-up moving to 2.0+, is that folks who need MRI 1.8 can still set the mime-types requirement in their Gemfile.

Thank you very much for the mail gem!
Please consider merging this so you can make life easier for folks who need / want mime-types 2!

Collaborator

bf4 commented Jun 8, 2014

2.6.1 is released with mime-types support up to 3 and is merged into Rails 4 through edge!

@bf4 bf4 closed this Jun 8, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment