The Converse.js library, ready to play with Rails
Ruby
Latest commit 9b900fd Sep 8, 2016 @mikemarsian version 1.0.4
Permalink
Failed to load latest commit information.
lib/conversejs version 1.0.4 Sep 7, 2016
vendor/assets version 1.0.4 Sep 7, 2016
.gitignore version 1.0.4 Sep 7, 2016
Gemfile first version Jul 21, 2016
LICENSE.txt first version Jul 21, 2016
README.md Update README.md Jul 22, 2016
Rakefile first version Jul 21, 2016
conversejs-rails.gemspec first version Jul 21, 2016

README.md

conversejs-rails

conversejs-rails wraps the Converse.js library in a rails engine for simple use with the asset pipeline provided by Rails 3.1 and higher. The gem includes the development (non-minified) source for ease of exploration. The asset pipeline will minify it in production.

Converse.js is a web based XMPP/Jabber instant messaging client. It enables you to add chat functionality to your website, independent of any specific backend. You will however need an XMPP server to connect to, either your own, or a public one.

Usage

Add the following to your Gemfile:

gem 'conversejs-rails'

Add the following directive to your Javascript manifest file (application.js):

//= require converse

If you receive javascript errors like these, try adding converse.js and converse.css manually in your layout file, after all other javascripts:

<html>
    <head>
        <!-- all of your js and css files here -->
        <!--            .....                  -->
        <%= stylesheet_link_tag "converse" %>
        <%= javascript_include_tag "converse" %>
    </head>
...

Versioning

conversejs-rails 1.0.3 == Converse.js 1.0.3

Every attempt is made to mirror the currently shipping Converse.js version number wherever possible. The major, minor, and patch version numbers will always represent the Converse.js version. Should a gem bug be discovered, a 4th version identifier will be added and incremented.