Running wicked_pdf on jruby #67

Closed
mbhandek opened this Issue Dec 12, 2011 · 1 comment

Comments

Projects
None yet
2 participants
@mbhandek

Hi mileszs!

We have an RoR 2.3.x based application built which uses wicked_pdf. It is working beautifully.
We switched to JRuby based platform for some corporate decision and we are in the process of migrating the project to be able to work on JRuby.

When we invoke wicked_pdf, it gives error with the 'fork' call since it is not present in JRuby.
Would it be possible for you to replace it with popen equivalent and release new gem?

Regards,
Manish

@unixmonkey

This comment has been minimized.

Show comment Hide comment
@unixmonkey

unixmonkey Jan 7, 2013

Collaborator

I don't think this issue is valid anymore. WickedPdf now uses Open3.popen3.
Feel free to reopen if you are still having this issue with the current version.

Collaborator

unixmonkey commented Jan 7, 2013

I don't think this issue is valid anymore. WickedPdf now uses Open3.popen3.
Feel free to reopen if you are still having this issue with the current version.

@unixmonkey unixmonkey closed this Jan 7, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment