Skip to content
Permalink
Browse files

Fix error message caused by adding new parameter to background (#8922)

Adds background9[] element to keep backwards compatibility in formspec prepends.
  • Loading branch information
rubenwardy authored and SmallJoker committed Sep 29, 2019
1 parent 16865a5 commit 07bdd6049b6d190de69419cc9be2ac49d3a08e0f
Showing with 3 additions and 3 deletions.
  1. +1 −1 doc/lua_api.txt
  2. +2 −2 src/gui/guiFormSpecMenu.cpp
@@ -2114,7 +2114,7 @@ Elements
* If `auto_clip` is `true`, the background is clipped to the formspec size
(`x` and `y` are used as offset values, `w` and `h` are ignored)

### `background[<X>,<Y>;<W>,<H>;<texture name>;<auto_clip>;<middle>]`
### `background9[<X>,<Y>;<W>,<H>;<texture name>;<auto_clip>;<middle>]`

* 9-sliced background. See https://en.wikipedia.org/wiki/9-slice_scaling
* Middle is a rect which defines the middle of the 9-slice.
@@ -2231,8 +2231,8 @@ void GUIFormSpecMenu::parseElement(parserData* data, const std::string &element)
return;
}

if (type == "background") {
parseBackground(data,description);
if (type == "background" || type == "background9") {
parseBackground(data, description);
return;
}

0 comments on commit 07bdd60

Please sign in to comment.
You can’t perform that action at this time.