Skip to content
Permalink
Browse files
Enable mod security by default
  • Loading branch information
ShadowNinja authored and paramat committed Oct 16, 2016
1 parent c31e354 commit 2ff054d0419535a9422a957d50491ed119d6eb73
Show file tree
Hide file tree
Showing 3 changed files with 3 additions and 3 deletions.
@@ -1161,7 +1161,7 @@ mgvalleys_np_inter_valley_slope (Valley Slope) noise_params 0.5, 0.5, (128, 128,
[*Security]

# Prevent mods from doing insecure things like running shell commands.
secure.enable_security (Enable mod security) bool false
secure.enable_security (Enable mod security) bool true

# Comma-separated list of trusted mods that are allowed to access insecure
# functions even when mod security is on (via request_insecure_environment()).
@@ -1507,7 +1507,7 @@

# Prevent mods from doing insecure things like running shell commands.
# type: bool
# secure.enable_security = false
# secure.enable_security = true

# Comma-separated list of trusted mods that are allowed to access insecure
# functions even when mod security is on (via request_insecure_environment()).
@@ -301,7 +301,7 @@ void set_default_settings(Settings *settings)
settings->setDefault("emergequeue_limit_diskonly", "32");
settings->setDefault("emergequeue_limit_generate", "32");
settings->setDefault("num_emerge_threads", "1");
settings->setDefault("secure.enable_security", "false");
settings->setDefault("secure.enable_security", "true");
settings->setDefault("secure.trusted_mods", "");
settings->setDefault("secure.http_mods", "");

0 comments on commit 2ff054d

Please sign in to comment.