Skip to content
Permalink
Browse files
Remove support for optdepends.txt
  • Loading branch information
ShadowNinja committed Dec 13, 2013
1 parent e275b70 commit 83853ccd413c06a4a37a3c91f8c2cb270e42109c
Show file tree
Hide file tree
Showing 2 changed files with 0 additions and 17 deletions.
@@ -129,13 +129,6 @@ screenshot.png:
description.txt:
File containing desctiption to be shown within mainmenu.

optdepends.txt:
An alternative way of specifying optional dependencies.
Like depends.txt, a single line contains a single modname.

NOTE: This file exists for compatibility purposes only and
support for it will be removed from the engine by the end of 2013.

init.lua:
The main Lua script. Running this script should register everything it
wants to register. Subsequent execution depends on minetest calling the
@@ -77,16 +77,6 @@ void parseModContents(ModSpec &spec)
}
}
}

// FIXME: optdepends.txt is deprecated
// remove this code at some point in the future
std::ifstream is2((spec.path+DIR_DELIM+"optdepends.txt").c_str());
while(is2.good()){
std::string dep;
std::set<char> symbols;
if(parseDependsLine(is2, dep, symbols))
spec.optdepends.insert(dep);
}
}
}

0 comments on commit 83853cc

Please sign in to comment.