Skip to content
Permalink
Browse files
Look for PostgreSQL library properly and fix CI
  • Loading branch information
sfan5 committed Apr 20, 2021
1 parent 1da7341 commit a24899bf2dcd58916922d671ee8761448b6876e5
Showing with 12 additions and 4 deletions.
  1. +1 −1 README.md
  2. +10 −1 src/CMakeLists.txt
  3. +1 −2 util/ci/common.sh
@@ -133,7 +133,7 @@ Compiling
| Dependency | Version | Commentary |
|------------|---------|------------|
| GCC | 4.9+ | Can be replaced with Clang 3.4+ |
| CMake | 2.6+ | |
| CMake | 3.5+ | |
| Irrlicht | - | Custom version required, see https://github.com/minetest/irrlicht |
| SQLite3 | 3.0+ | |
| LuaJIT | 2.0+ | Bundled Lua 5.1 is used if not present |
@@ -146,7 +146,16 @@ option(ENABLE_POSTGRESQL "Enable PostgreSQL backend" TRUE)
set(USE_POSTGRESQL FALSE)

if(ENABLE_POSTGRESQL)
find_package("PostgreSQL")
if(CMAKE_VERSION VERSION_LESS "3.20")
find_package(PostgreSQL QUIET)
# Before CMake 3.20 FindPostgreSQL.cmake always looked for server includes
# but we don't need them, so continue anyway if only those are missing.
if(PostgreSQL_INCLUDE_DIR AND PostgreSQL_LIBRARY)
set(PostgreSQL_FOUND TRUE)
endif()
else()
find_package(PostgreSQL)
endif()

if(PostgreSQL_FOUND)
set(USE_POSTGRESQL TRUE)
@@ -5,8 +5,7 @@ install_linux_deps() {
local pkgs=(cmake libpng-dev \
libjpeg-dev libxxf86vm-dev libgl1-mesa-dev libsqlite3-dev \
libhiredis-dev libogg-dev libgmp-dev libvorbis-dev libopenal-dev \
gettext libpq-dev postgresql-server-dev-all libleveldb-dev \
libcurl4-openssl-dev)
gettext libpq-dev libleveldb-dev libcurl4-openssl-dev)

if [[ "$1" == "--old-irr" ]]; then
shift

0 comments on commit a24899b

Please sign in to comment.