Skip to content
Permalink
Browse files
Add debian 11 to Gitlab-CI (#11571)
* feat(gitlab-ci): add debian 11 support
  • Loading branch information
nerzhul committed Aug 27, 2021
1 parent ff3aa18 commit a7188bd6f55993d9ca6075b0b6a462c1e7e06412
Showing with 29 additions and 2 deletions.
  1. +28 −1 .gitlab-ci.yml
  2. +1 −1 misc/debpkg-control
@@ -45,6 +45,7 @@ variables:
- sed -i 's/DATEPLACEHOLDER/'$(date +%y.%m.%d)'/g' build/deb/minetest/DEBIAN/control
- sed -i 's/JPEG_PLACEHOLDER/'$JPEG_PKG'/g' build/deb/minetest/DEBIAN/control
- sed -i 's/LEVELDB_PLACEHOLDER/'$LEVELDB_PKG'/g' build/deb/minetest/DEBIAN/control
- sed -i 's/JSONCPP_PLACEHOLDER/'$JSONCPP_PKG'/g' build/deb/minetest/DEBIAN/control
- cd build/deb/ && dpkg-deb -b minetest/ && mv minetest.deb ../../
artifacts:
expire_in: 90 day
@@ -54,7 +55,7 @@ variables:
.debpkg_install:
stage: deploy
before_script:
- apt-get update
- apt-get update -qy
script:
- apt-get install -y ./*.deb
- minetest --version
@@ -75,6 +76,7 @@ package:debian-9:
needs:
- build:debian-9
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1v5
JPEG_PKG: libjpeg62-turbo

@@ -96,6 +98,7 @@ package:debian-10:
needs:
- build:debian-10
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1d
JPEG_PKG: libjpeg62-turbo

@@ -105,6 +108,28 @@ deploy:debian-10:
needs:
- package:debian-10

# Bullseye

build:debian-11:
extends: .build_template
image: debian:11

package:debian-11:
extends: .debpkg_template
image: debian:11
needs:
- build:debian-11
variables:
JSONCPP_PKG: libjsoncpp24
LEVELDB_PKG: libleveldb1d
JPEG_PKG: libjpeg62-turbo

deploy:debian-11:
extends: .debpkg_install
image: debian:11
needs:
- package:debian-11

##
## Ubuntu
##
@@ -121,6 +146,7 @@ package:ubuntu-16.04:
needs:
- build:ubuntu-16.04
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1v5
JPEG_PKG: libjpeg-turbo8

@@ -142,6 +168,7 @@ package:ubuntu-18.04:
needs:
- build:ubuntu-18.04
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1v5
JPEG_PKG: libjpeg-turbo8

@@ -3,7 +3,7 @@ Priority: extra
Standards-Version: 3.6.2
Package: minetest-staging
Version: 5.4.0-DATEPLACEHOLDER
Depends: libc6, libcurl3-gnutls, libfreetype6, libgl1, JPEG_PLACEHOLDER, libjsoncpp1, LEVELDB_PLACEHOLDER, libopenal1, libpng16-16, libsqlite3-0, libstdc++6, libvorbisfile3, libx11-6, libxxf86vm1, zlib1g
Depends: libc6, libcurl3-gnutls, libfreetype6, libgl1, JPEG_PLACEHOLDER, JSONCPP_PLACEHOLDER, LEVELDB_PLACEHOLDER, libopenal1, libpng16-16, libsqlite3-0, libstdc++6, libvorbisfile3, libx11-6, libxxf86vm1, zlib1g
Maintainer: Loic Blot <loic.blot@unix-experience.fr>
Homepage: https://www.minetest.net/
Vcs-Git: https://github.com/minetest/minetest.git

0 comments on commit a7188bd

Please sign in to comment.