Skip to content
Permalink
Browse files
Drop Ubuntu 16.04 from gitlab-ci, add 20.04 instead
  • Loading branch information
sfan5 committed Sep 1, 2021
1 parent 70dafcf commit e5edda28ce3ba123464d08a37e3f81005b727305
Showing with 20 additions and 20 deletions.
  1. +20 −20 .gitlab-ci.yml
@@ -17,7 +17,7 @@ variables:
stage: build
before_script:
- apt-get update
- apt-get -y install build-essential git cmake libpng-dev libjpeg-dev libxxf86vm-dev libgl1-mesa-dev libsqlite3-dev libleveldb-dev libogg-dev libvorbis-dev libopenal-dev libcurl4-gnutls-dev libfreetype6-dev zlib1g-dev libgmp-dev libjsoncpp-dev libzstd-dev
- DEBIAN_FRONTEND=noninteractive apt-get -y install build-essential git cmake libpng-dev libjpeg-dev libxxf86vm-dev libgl1-mesa-dev libsqlite3-dev libleveldb-dev libogg-dev libvorbis-dev libopenal-dev libcurl4-gnutls-dev libfreetype6-dev zlib1g-dev libgmp-dev libjsoncpp-dev libzstd-dev
script:
- git clone https://github.com/minetest/irrlicht -b $IRRLICHT_TAG lib/irrlichtmt
- mkdir cmakebuild
@@ -134,49 +134,49 @@ deploy:debian-11:
## Ubuntu
##

# Xenial
# Bionic

build:ubuntu-16.04:
build:ubuntu-18.04:
extends: .build_template
image: ubuntu:xenial
image: ubuntu:bionic

package:ubuntu-16.04:
package:ubuntu-18.04:
extends: .debpkg_template
image: ubuntu:xenial
image: ubuntu:bionic
needs:
- build:ubuntu-16.04
- build:ubuntu-18.04
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1v5
JPEG_PKG: libjpeg-turbo8

deploy:ubuntu-16.04:
deploy:ubuntu-18.04:
extends: .debpkg_install
image: ubuntu:xenial
image: ubuntu:bionic
needs:
- package:ubuntu-16.04
- package:ubuntu-18.04

# Bionic
# Focal

build:ubuntu-18.04:
build:ubuntu-20.04:
extends: .build_template
image: ubuntu:bionic
image: ubuntu:focal

package:ubuntu-18.04:
package:ubuntu-20.04:
extends: .debpkg_template
image: ubuntu:bionic
image: ubuntu:focal
needs:
- build:ubuntu-18.04
- build:ubuntu-20.04
variables:
JSONCPP_PKG: libjsoncpp1
LEVELDB_PKG: libleveldb1v5
LEVELDB_PKG: libleveldb1d
JPEG_PKG: libjpeg-turbo8

deploy:ubuntu-18.04:
deploy:ubuntu-20.04:
extends: .debpkg_install
image: ubuntu:bionic
image: ubuntu:focal
needs:
- package:ubuntu-18.04
- package:ubuntu-20.04

##
## Fedora

0 comments on commit e5edda2

Please sign in to comment.