Skip to content

Commit

Permalink
Browse files Browse the repository at this point in the history
Reduce ore noise_parms error to deprecation warning (#10921)
Fixes #10914
  • Loading branch information
rubenwardy committed Feb 6, 2021
1 parent 0f74c7a commit fbb9ef3
Showing 1 changed file with 2 additions and 4 deletions.
6 changes: 2 additions & 4 deletions src/script/lua_api/l_mapgen.cpp
Expand Up @@ -1336,10 +1336,8 @@ int ModApiMapgen::l_register_ore(lua_State *L)
if (read_noiseparams(L, -1, &ore->np)) {
ore->flags |= OREFLAG_USE_NOISE;
} else if (ore->needs_noise) {
errorstream << "register_ore: specified ore type requires valid "
"'noise_params' parameter" << std::endl;
delete ore;
return 0;
log_deprecated(L,
"register_ore: ore type requires 'noise_params' but it is not specified, falling back to defaults");
}
lua_pop(L, 1);

Expand Down

0 comments on commit fbb9ef3

Please sign in to comment.