Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Framerate cut in half, HUD problem ? #2252

Closed
tenplus1 opened this Issue Feb 2, 2015 · 6 comments

Comments

Projects
None yet
2 participants
@tenplus1
Copy link
Contributor

tenplus1 commented Feb 2, 2015

For some reason the latest 0.4.11 daily builds have cut my frames per second in half... Where 0.4.11 was running at a smooth 30fps and over, Build 3404 for linux/ubuntu is running 15fps and is jittery...

By pressing F1 to turn off the HUD, framerate jumps back up to 40fps so something is up with that it seems...

@Zeno-

This comment has been minimized.

Copy link
Contributor

Zeno- commented Feb 2, 2015

Do you experience this on all servers (and also single player games)?

@tenplus1

This comment has been minimized.

Copy link
Contributor Author

tenplus1 commented Feb 3, 2015

Framerate drops dramatically in server mode but only a few fps in standalone games...

@Zeno-

This comment has been minimized.

Copy link
Contributor

Zeno- commented Feb 4, 2015

Do you know which commit caused the problem (in other words, where the problem began)?

I cannot reproduce. There is a difference of about 5% for the render loop with HUD enabled/disabled but as far as I can tell that was probably always there (you'd have to expect some difference with HUD enabled/disabled; 5% is perhaps too much but it's not 50%). I'm not saying it doesn't happen for you but if you can nail it down to a single commit that causes the issue it would go a long way towards fixing it.

@tenplus1

This comment has been minimized.

Copy link
Contributor Author

tenplus1 commented Feb 4, 2015

Unfortunately I can only guess at 5 builds ago previous to the current... I try to download the latest as they appear and test new changes and the last few were very slow and glitchy until HUD disabled...

@Zeno-

This comment has been minimized.

Copy link
Contributor

Zeno- commented Feb 5, 2015

Ok, running under valgrind there appears there may be up to ~4-5x increase in drawtime with HUD enabled

@Zeno-

This comment has been minimized.

Copy link
Contributor

Zeno- commented Feb 5, 2015

Thanks @tenplus1

commit 9a0dd47

@Zeno- Zeno- closed this Feb 5, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.