Permalink
Browse files

import ioloop from zmq, not tornado

in sockjs-tornado

tornado >= 2.5 makes a minor change in the IOLoop API,
so tornado.ioloop.PeriodicCallback >= 2.5 will not work with
IOLoop from pyzmq < 3.2.
  • Loading branch information...
1 parent 62faaaa commit c49bce179f210f10b01bfd3128d1a7d270060379 @minrk committed Jan 18, 2013
Showing with 3 additions and 2 deletions.
  1. +2 −1 IPython/external/sockjs/tornado/router.py
  2. +1 −1 IPython/external/sockjs/tornado/stats.py
@@ -6,7 +6,8 @@
SockJS protocol router implementation.
"""
-from tornado import ioloop, version_info
+from tornado import version_info
+from zmq.eventloop import ioloop
from IPython.external.sockjs.tornado import transports, session, sessioncontainer, static, stats, proto
@@ -1,6 +1,6 @@
from collections import deque
-from tornado import ioloop
+from zmq.eventloop import ioloop
class MovingAverage(object):

0 comments on commit c49bce1

Please sign in to comment.