Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The problem of $COMPOSER_PREFER_LOWEST variable #1

Closed
peter279k opened this issue Sep 8, 2019 · 2 comments

Comments

@peter279k
Copy link
Contributor

commented Sep 8, 2019

As title, it looks like the composer update command option relies on this $COMPOSER_PREFER_LOWEST environment variable.

Actually, we cannot find where this environment variable is set currently.

To resolve this issue, we should do following tips:

  • Define a COMPOSER_PREFER_LOWEST environment vairable and set true to do the composer update --prefer-source command.
  • Define a COMPOSER_PREFER_LOWEST environment vairable and set false to do the composer update --prefer-source --prefer-lowest --prefer-stable command.

Once this issue is accepted, I'm happy to work on this.

@peter279k

This comment has been minimized.

Copy link
Contributor Author

commented Sep 8, 2019

BTW, here is a tutorial about setting environment variables on Travis CI build.

@devtronic

This comment has been minimized.

Copy link
Member

commented Sep 8, 2019

Thanks for opening the issue. I've assigned it to you.

I think the best way is to create a matrix entry in the .travis.yml to test both cases.

For example:

matrix:
  include:
  - name: "Prefer Source"
    env: COMPOSER_PREFER_LOWEST=false
  - name: "Prefer Lowest"
    env: COMPOSER_PREFER_LOWEST=true
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.