--parse-templates errror #23

Closed
philfreo opened this Issue Jul 27, 2012 · 0 comments

2 participants

@philfreo
(venv)[myapp] ./manage.py assets --parse-templates build
Searching templates...
Traceback (most recent call last):
  File "./manage.py", line 61, in <module>
    manager.run()
  File "/Users/philfreo/Sites/_es/myapp/venv/lib/python2.7/site-packages/flaskext/script.py", line 710, in run
    self.handle(sys.argv[0], command, sys.argv[2:])
  File "/Users/philfreo/Sites/_es/myapp/venv/lib/python2.7/site-packages/flaskext/script.py", line 682, in handle
    command.handle(app, *positional_args, **command_namespace.__dict__)
  File "/Users/philfreo/Sites/_es/myapp/venv/lib/python2.7/site-packages/flaskext/script.py", line 193, in handle
    self.run(*args, **kwargs)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/flask-assets/src/flask_assets.py", line 345, in run
    impl.main(args)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/webassets/src/webassets/script.py", line 555, in main
    return self.run_with_argv(argv)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/webassets/src/webassets/script.py", line 547, in run_with_argv
    return self.run_with_ns(ns)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/webassets/src/webassets/script.py", line 529, in run_with_ns
    env = self._setup_assets_env(ns, log)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/flask-assets/src/flask_assets.py", line 287, in _setup_assets_env
    env.add(*[b for b in self.load_from_templates(env)
  File "/Users/philfreo/Sites/_es/myapp/venv/src/flask-assets/src/flask_assets.py", line 309, in load_from_templates
    path.join(blueprint.root_path, blueprint.template_folder))
AttributeError: 'str' object has no attribute 'root_path'

Looks like blueprint is a string for all the blueprints in app.blueprints. Did I setup something wrong or is this a bug?

@miracle2k miracle2k closed this in 20e3451 Jul 28, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment