Skip to content

1.9 support / 1.7.0.preview1 bugs #188

Closed
baroquebobcat opened this Issue Jul 22, 2012 · 1 comment

1 participant

@baroquebobcat
The Mirah Community member

master and newast both have issues with 1.9

          [NativeException] exception expected, not
          Class: <Java::JavaLang::Exception>
          Message: <"!x">

errors should be easy, because they reflect an API change.

1.9 API changes

          assertion message must be String or Proc, but Fixnum was given.
        @ test/core/ast_test.rb:351:in `test_return'

update: above is a bug where we use assert instead of assert_equal

also newast uses each_with_index on strings in a few places, and that causes errors.

There's also these problems:


             ERROR (0:00:14.249) test_unquote_method_definitions_with_main
          argument type mismatch

so those are probably ok.

@baroquebobcat
The Mirah Community member

I think we've got all these.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.