Shell_cmd or cmd is required error #55

Closed
lmartins opened this Issue Dec 3, 2013 · 8 comments

4 participants

@lmartins

Im getting the following:

shell_cmd or cmd is required
[cmd: ]
[dir: /Users/luismartins/Sites/webipack018/themes/front]
[path: /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/sbin:/usr/local/share/npm/bin]
[Finished]

am I missing something on my configuration?

@EdVanDance

Probably ST3?
ST3 is not supported, see #49.

@lmartins

Yes, this is in ST3.
Package Controls signals this package as compatible, you may wan't to review that.

Any plans on making the plugin compatible with ST3?

Thanks.

@EdVanDance
@misfo
Owner

I have updated the plugin to work with ST3, but I can't reproduce that error. What OS & version of Sublime Text do you have? What steps does it take to reproduce?

@lmartins

Uninstalled and installed again, it runs fine now.
I have no idea of what was going on.
Thanks!

@lmartins lmartins closed this Dec 3, 2013
@misfo
Owner

@mreinhardt reported the same issue in #51. It's triggered by going back in the shell history before executing. I'll take a look at it...

@misfo misfo reopened this Dec 3, 2013
@misfo misfo added a commit that closed this issue Dec 6, 2013
@misfo Fix readline issues in Sublime Text 3
The code loading mechanism must have changed in ST3 because moving the code in
sublime_readline.py to the main file fixed it...

Fixes #55
a24bc8e
@misfo misfo closed this in a24bc8e Dec 6, 2013
@misfo
Owner

This is fixed now. Re-open this ticket or comment here if you're still having issues

@bryansray

I'm still seeing this issue. I was able to solve it by entering this in to the Dart.sublime-build file.

"cmd": ["dart", "$file"]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment